games-strategy/wesnoth: Fix build with boost-1.70
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 26 Jul 2019 18:21:23 +0000 (20:21 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 26 Jul 2019 18:23:30 +0000 (20:23 +0200)
Closes: https://bugs.gentoo.org/690772
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-strategy/wesnoth/files/wesnoth-1.14.7-boost-1.70.patch [new file with mode: 0644]
games-strategy/wesnoth/wesnoth-1.14.7.ebuild

diff --git a/games-strategy/wesnoth/files/wesnoth-1.14.7-boost-1.70.patch b/games-strategy/wesnoth/files/wesnoth-1.14.7-boost-1.70.patch
new file mode 100644 (file)
index 0000000..90c5267
--- /dev/null
@@ -0,0 +1,24 @@
+From 9d0e3bae096563297c9f51355968f27a67dbfdec Mon Sep 17 00:00:00 2001
+From: Charles Dang <exodia339@gmail.com>
+Date: Mon, 15 Jul 2019 03:18:31 +1100
+Subject: [PATCH] Removed redundant std::ref causing problems with Boost 1.70
+ (fixes #3990)
+
+The asio socket ctor already takes a reference.
+---
+ src/server/server_base.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/server/server_base.cpp b/src/server/server_base.cpp
+index 82b46e912025..8bcf974a62d1 100644
+--- a/src/server/server_base.cpp
++++ b/src/server/server_base.cpp
+@@ -65,7 +65,7 @@ void server_base::start_server()
+ void server_base::serve()
+ {
+-      socket_ptr socket = std::make_shared<boost::asio::ip::tcp::socket>(std::ref(io_service_));
++      socket_ptr socket = std::make_shared<boost::asio::ip::tcp::socket>(io_service_);
+       acceptor_.async_accept(*socket, std::bind(&server_base::accept_connection, this, _1, socket));
+ }
index 971ba1f87a94509043d9a4519f2b0e97f0bb2ad6..e0b1b37602ec26794a8d3146982b025a44b8a80f 100644 (file)
@@ -40,6 +40,8 @@ BDEPEND="
        virtual/pkgconfig
 "
 
+PATCHES=( "${FILESDIR}"/${P}-boost-1.70.patch )
+
 pkg_setup() {
        if use openmp; then
                tc-has-openmp || die "Please switch to an openmp compatible compiler"