dev-ml/num: use CFLAGS
authorAlfredo Tupone <tupone@gentoo.org>
Thu, 21 May 2020 17:04:09 +0000 (19:04 +0200)
committerAlfredo Tupone <tupone@gentoo.org>
Thu, 21 May 2020 17:04:09 +0000 (19:04 +0200)
Closes: https://bugs.gentoo.org/723748
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ml/num/files/num-1.3-cflags.patch [new file with mode: 0644]
dev-ml/num/num-1.3.ebuild

diff --git a/dev-ml/num/files/num-1.3-cflags.patch b/dev-ml/num/files/num-1.3-cflags.patch
new file mode 100644 (file)
index 0000000..771455c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/Makefile     2020-05-21 18:54:31.176399032 +0200
++++ b/src/Makefile     2020-05-21 18:55:27.881498310 +0200
+@@ -65,7 +65,7 @@
+ %.cmx: %.ml
+       $(OCAMLOPT) $(CAMLOPTFLAGS) -c $*.ml
+ %.$(O): %.c
+-      $(OCAMLC) -ccopt -DBNG_ARCH_$(BNG_ARCH) -c $*.c
++      $(OCAMLC) -ccopt "-DBNG_ARCH_$(BNG_ARCH) $(CFLAGS)" -c $*.c
+ # Legacy installation: files go into OCaml's stdlib directory; only META
+ # is installed via findlib
index aaa82b73caa0489fbf93327ce8b89f680edd24f7..8cea14497085b600e55c4cfad2e702e777fc396c 100644 (file)
@@ -19,6 +19,14 @@ DEPEND=">=dev-lang/ocaml-4.09.0[ocamlopt]
 RDEPEND="${DEPEND}"
 BDEPEND="${DEPEND}"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_compile() {
+       emake CFLAGS="${CFLAGS}"
+}
+
 src_install() {
        findlib_src_preinst
        OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}"