net-dialup/linux-atm: tweak for linux-headers-5.2
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 20 Jul 2019 11:45:09 +0000 (12:45 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 20 Jul 2019 11:45:19 +0000 (12:45 +0100)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-dialup/linux-atm/files/linux-atm-2.5.2-linux-5.2-SIOCGSTAMP.patch [new file with mode: 0644]
net-dialup/linux-atm/linux-atm-2.5.2.ebuild

diff --git a/net-dialup/linux-atm/files/linux-atm-2.5.2-linux-5.2-SIOCGSTAMP.patch b/net-dialup/linux-atm/files/linux-atm-2.5.2-linux-5.2-SIOCGSTAMP.patch
new file mode 100644 (file)
index 0000000..ff91c7f
--- /dev/null
@@ -0,0 +1,41 @@
+Fix build failure against linux-5.2+:
+  https://www.spinics.net/lists/linux-sh/msg53430.html
+
+--- a/src/maint/atmdump.c
++++ b/src/maint/atmdump.c
+@@ -17,6 +17,16 @@
+ #include <netinet/in.h> /* for htonl and ntohl */
+ #include <atm.h>
++#ifndef SIOCGSTAMP
++/* linux-5.2+ added support for 64-bit time_t into ioctls
++   that support 'struct timeval' and removed 'SIOCGSTAMP'
++   define.
++
++   Include 'SIOCGSTAMP' wrapper via linux/sockios.h
++   if does not exist.
++  */
++#    include <linux/sockios.h>
++#endif
+ static const char *pti[] = { "Data SDU 0","Data SDU 1","Data SDU 0, CE",
+   "Data SDU 1, CE","Segment OAM F5","End-to-end OAM F5","Reserved (RM)",
+--- a/src/maint/saaldump.c
++++ b/src/maint/saaldump.c
+@@ -24,6 +24,16 @@
+ #define MAX_ITEM  2048 /* longest string emitted by q.dump */
++#ifndef SIOCGSTAMP
++/* linux-5.2+ added support for 64-bit time_t into ioctls
++   that support 'struct timeval' and removed 'SIOCGSTAMP'
++   define.
++
++   Include 'SIOCGSTAMP' wrapper via linux/sockios.h
++   if does not exist.
++  */
++#    include <linux/sockios.h>
++#endif
+ static int interval = 0; /* display absolute time by default */
+ static int quiet = 0; /* decode Q.2931 messages by default */
index 3ea9f3d5e198d91fe68201577c19030aef6610b2..7bc4fa72eed5f6a257d5d09a7f305df0369c54e7 100644 (file)
@@ -25,6 +25,7 @@ CONFIG_CHECK="~ATM"
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-headers.patch
+       epatch "${FILESDIR}"/${P}-linux-5.2-SIOCGSTAMP.patch
 
        sed -i '/#define _LINUX_NETDEVICE_H/d' \
                src/arpd/*.c || die "sed command on arpd/*.c files failed"