games-board/pokerth: add patch for boost-1.73
authorStefan Strogin <steils@gentoo.org>
Mon, 18 May 2020 01:30:28 +0000 (04:30 +0300)
committerStefan Strogin <steils@gentoo.org>
Mon, 18 May 2020 01:33:27 +0000 (04:33 +0300)
Closes: https://bugs.gentoo.org/723520
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Stefan Strogin <steils@gentoo.org>
games-board/pokerth/files/pokerth-1.1.2-boost-1.73.patch [new file with mode: 0644]
games-board/pokerth/pokerth-1.1.2.ebuild

diff --git a/games-board/pokerth/files/pokerth-1.1.2-boost-1.73.patch b/games-board/pokerth/files/pokerth-1.1.2-boost-1.73.patch
new file mode 100644 (file)
index 0000000..9733ffa
--- /dev/null
@@ -0,0 +1,42 @@
+From a769887330a317d55e7f64c71a32ad130ffb9307 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Mon, 18 May 2020 03:30:53 +0300
+Subject: [PATCH] Fix using boost placeholders (#395)
+
+Bug: https://bugs.gentoo.org/723520
+Upstream-Status: Submitted [https://github.com/pokerth/pokerth/pull/396]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ src/net/common/serveracceptwebhelper.cpp | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/net/common/serveracceptwebhelper.cpp b/src/net/common/serveracceptwebhelper.cpp
+index f61d4d77..8701e1e9 100644
+--- a/src/net/common/serveracceptwebhelper.cpp
++++ b/src/net/common/serveracceptwebhelper.cpp
+@@ -29,6 +29,7 @@
+  * as that of the covered work.                                              *
+  *****************************************************************************/
++#include <boost/bind/bind.hpp>
+ #include <net/serveracceptwebhelper.h>
+ #include <net/sessiondata.h>
+ #include <net/webreceivebuffer.h>
+@@ -58,10 +59,10 @@ ServerAcceptWebHelper::Listen(unsigned serverPort, bool /*ipv6*/, const std::str
+       m_webSocketServer->init_asio(m_ioService.get());
+-      m_webSocketServer->set_validate_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::validate), this, _1));
+-      m_webSocketServer->set_open_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_open), this, _1));
+-      m_webSocketServer->set_close_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_close), this, _1));
+-      m_webSocketServer->set_message_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_message), this, _1, _2));
++      m_webSocketServer->set_validate_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::validate), this, boost::placeholders::_1));
++      m_webSocketServer->set_open_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_open), this, boost::placeholders::_1));
++      m_webSocketServer->set_close_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_close), this, boost::placeholders::_1));
++      m_webSocketServer->set_message_handler(boost::bind(boost::mem_fn(&ServerAcceptWebHelper::on_message), this, boost::placeholders::_1, boost::placeholders::_2));
+       m_webSocketServer->listen(serverPort);
+       m_webSocketServer->start_accept();
+-- 
+2.26.2
+
index 08afd16fde1928a64e6a54e61f5f309cb069534e..4414a4a4561cd2f4d5cad7bd23b3dce133d77008 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -44,6 +44,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-1.1.2-fix-includes.patch
        # unbundle dev-cpp/websocketpp
        "${FILESDIR}"/${PN}-1.1.2-system-websockets.patch
+       "${FILESDIR}"/${PN}-1.1.2-boost-1.73.patch
 )
 
 src_prepare() {