sys-apps/udevil: revbump, fixes bug 580364
authorDaniel Campbell <zlg@gentoo.org>
Mon, 2 Jan 2017 15:38:26 +0000 (07:38 -0800)
committerDaniel Campbell <zlg@gentoo.org>
Mon, 2 Jan 2017 15:38:44 +0000 (07:38 -0800)
Upstream is adopting a similar fix and it won't be needed for 0.4.5.

Gentoo-Bug: 580364
Gentoo-Bug-URL: https://bugs.gentoo.org/580364

Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-apps/udevil/files/udevil-0.4.4-include-sysmacros.patch [new file with mode: 0644]
sys-apps/udevil/udevil-0.4.4-r2.ebuild [new file with mode: 0644]

diff --git a/sys-apps/udevil/files/udevil-0.4.4-include-sysmacros.patch b/sys-apps/udevil/files/udevil-0.4.4-include-sysmacros.patch
new file mode 100644 (file)
index 0000000..7adda28
--- /dev/null
@@ -0,0 +1,15 @@
+# Include sysmacros.h, solves Gentoo bug 580364
+# Upstream has merged similar changes, should be present
+# in 0.4.5
+--- a/src/udevil.c     2015-05-04 06:34:32.000000000 -0700
++++ b/src/udevil.c     2017-01-02 07:25:14.744273858 -0800
+@@ -33,6 +33,9 @@
+ #include <netdb.h>
+ #include <arpa/inet.h>
++// major/minor, dev_t, needed for glibc>=2.25
++#include <sys/sysmacros.h>
++
+ // groups
+ #include <grp.h>
diff --git a/sys-apps/udevil/udevil-0.4.4-r2.ebuild b/sys-apps/udevil/udevil-0.4.4-r2.ebuild
new file mode 100644 (file)
index 0000000..864ac30
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="https://ignorantguru.github.com/udevil/"
+SRC_URI="https://github.com/IgnorantGuru/udevil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-4.0:*
+       dev-libs/glib:2
+       sys-apps/util-linux
+       virtual/acl
+       >=virtual/udev-143"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+pkg_setup(){
+       enewgroup plugdev
+}
+
+src_prepare() {
+       # This works for 0.4.4 too, no sense copying the patch
+       epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
+       epatch "${FILESDIR}"/${P}-stat.patch
+       epatch "${FILESDIR}"/${P}-include-sysmacros.patch
+       eapply_user
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --with-setfacl-prog="$(type -P setfacl)" \
+               --enable-systemd
+}
+
+src_install() {
+       default
+       fowners root:plugdev /usr/bin/udevil
+       fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+       einfo
+       elog "Please add your user to the plugdev group"
+       elog "to be able to use ${PN} as a user"
+       elog
+       elog "Optional dependencies:"
+       elog "  gnome-extra/zenity (devmon popups)"
+       elog "  net-fs/davfs2      (mount WebDAV resources)"
+       elog "  net-fs/cifs-utils  (mounting samba shares)"
+       elog "  net-fs/curlftpfs   (mounting ftp shares)"
+       elog "  net-fs/nfs-utils   (mounting nfs shares)"
+       elog "  net-fs/sshfs       (mounting sftp shares)"
+       elog "  virtual/eject      (eject via devmon)"
+       if ! has_version 'sys-fs/udisks' ; then
+               elog
+               elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+               elog "you may need to enable kernel polling for device media changes to be detected."
+               elog "See https://ignorantguru.github.com/${PN}/#polling"
+               has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+               kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+               einfo
+       fi
+}