dev-ml/camlp5: version bump
authorTupone Alfredo <tupone@gentoo.org>
Wed, 15 Jan 2020 08:16:02 +0000 (09:16 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Wed, 15 Jan 2020 08:16:02 +0000 (09:16 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ml/camlp5/Manifest
dev-ml/camlp5/camlp5-7.10.ebuild [new file with mode: 0644]
dev-ml/camlp5/metadata.xml

index 893ad6f7a26d6a8b72a47790af86b18ccfd6ffa3..8b95932ffc1b957228da80b0e73daa2d199c0c6b 100644 (file)
@@ -2,3 +2,4 @@ DIST camlp5-6.17.tar.gz 718935 BLAKE2B b0a573e1110d6ce0654325a1a7310ebee8c815998
 DIST camlp5-7.00.tar.gz 755750 BLAKE2B b047422ff34c4d15c21b65bd7473ccdad8bfc1f484a0075f1beeaa50fdca72b2f900b437333c847a4e4fd7bb8ae5c37aa4ed984e3a850c4dcba045d8678502c4 SHA512 2d63451229f86fffeb287735ed26901ad43bb964b6ede1716cb82737001a5c1e4b77479a969509606f6a4f14bb6dbff32275d82f4a9640e0c16bb6594779e849
 DIST camlp5-7.01.tar.gz 757118 BLAKE2B 5d7c6f39f24bfee545552aae5c126305d2c767d06762aa516c21bcc5b327b312b7c38d742717eb507b92ae1e27de9c0fcde4d616754a7ce616b5f56689c8dc5a SHA512 9930957f707d9d2c8903f87f5f3444f71bad3d84c944436c7abc6de19209595c974098cd60a6a391f8ae87c4fb53b5122cba8e42e34fcf46d798dbdc28840008
 DIST camlp5-7.03.tar.gz 758136 BLAKE2B 4e1169adf7e119f1f659fe684a8b06c4730db3bcd7807169552de0e3fc115f8d45bc11961f3aee0a9c2d86e1130ec776a1bb7753d7d4e95f661d65d1f841406c SHA512 0c76d469c5f8c727088f3136107b6690349b50791ef8baefffdaa90141230907f977a7a886a9e8d88d39d8fa315637d882d0205c57d752e16575c888a8a1f54d
+DIST camlp5-7.10.tar.gz 849559 BLAKE2B b05624156e914c2657d76afbf3dfacd295fe5985ae3809959a40029a8052669be6ae8a6ff889fbf2c602d3f19c9995f013b388c140738f4bb4f4da9970911ed5 SHA512 faa9e88f56477162038fc80429d5839c93b3e38aec90366730babe737e2e6bb260dc39975947a6601212cc0c68f465bdbccb6337da23c07181909dfb11cf8640
diff --git a/dev-ml/camlp5/camlp5-7.10.ebuild b/dev-ml/camlp5/camlp5-7.10.ebuild
new file mode 100644 (file)
index 0000000..542b744
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/camlp5/camlp5/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="doc +ocamlopt"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES DEVEL ICHANGES README.md UPGRADING MODE"
+
+src_configure() {
+       ./configure \
+               --strict \
+               -prefix /usr \
+               -bindir /usr/bin \
+               -libdir /usr/$(get_libdir)/ocaml \
+               -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+       emake out
+       if use ocamlopt; then
+               emake  opt
+               emake  opt.opt
+       fi
+}
+
+src_install() {
+       use doc && HTML_DOCS="doc/*"
+
+       default
+
+       # findlib support
+       insinto "$(ocamlfind printconf destdir)/${PN}"
+       doins etc/META
+}
index ccabf3b60aee243bd7edd4acd7a67f4f7d3621ad..7994efd51d47b948d862aa090064445993f0d803 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>tupone@gentoo.org</email>
+               <name>Tupone Alfredo</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">camlp5/camlp5</remote-id>
        </upstream>