sci-calculators/units: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Wed, 1 Nov 2017 19:57:12 +0000 (20:57 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 1 Nov 2017 19:57:33 +0000 (20:57 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.4

sci-calculators/units/Manifest
sci-calculators/units/units-2.16.ebuild [new file with mode: 0644]

index 92f6ef4bd8cd4f52c3dfa2a34c6893552996dca4..57f84dcc73b7de4158138cf0c0ed4e8257fd521d 100644 (file)
@@ -1,2 +1,3 @@
 DIST units-2.14.tar.gz 1177024 SHA256 9d33893d82f3ddd831d5822992007c40bcd0826ae67d3cbc96539951fb0a82e8 SHA512 3cd09a76fb1cccbafaa3e023c791740738c8347425b2645cad1fa768dee3ebde917602cf65988ee8922fed512ec0bc2367f68545450789fc6bf1a79f066a6986 WHIRLPOOL ae4c0297387e9d3e42ae556a5f528f9c6f1b6a75f5f90580c5b9729ccdea011962d0e891c13ed583a97167bb62d5d074ab3b695ffdd23304f72a62098ce87821
 DIST units-2.15.tar.gz 1178099 SHA256 25d6334fafc801e15b3b0388e207e1efc5d4ae88af6dc7b17d3913de6441f47c SHA512 3fd60acd12142ea3c20bf39184394f300a8284a8946beaf89a8bf2f87c77d8a1ab02189c8a2fd3f93d64517945136fe4ea671edd2d48ea9bae55f9a87b30423f WHIRLPOOL ce17241a949c32a602f1a90683a82af973d51bb2ffdea35d9e7d2f23857271aa05519ee4c22eff9c4df9db590115dfd097b1637c4ce58762eebc8afd5e493c95
+DIST units-2.16.tar.gz 1178197 SHA256 dcf3f78482a13b150fc6bf0f8d611510816a3424bc2b26229b85b1cadeb81686 SHA512 afca2bf313208db2d0a3f4e96fed7bb86a3e96030b420e1cfa68a140499b9a8f2ef8c166c1d608d03c9ca6260199569a67c67c623d8c6a4b8d52e9d5cb6e3091 WHIRLPOOL c3d483e9f1b9343716f3a1c041e4bf9cb4f75c088664c14dde96ec9cbed2add9bec1f448d1f0a9767c7e0d66e9eac6c306b2afe614d05dc845b5b213a162af5d
diff --git a/sci-calculators/units/units-2.16.ebuild b/sci-calculators/units/units-2.16.ebuild
new file mode 100644 (file)
index 0000000..052a0fa
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units_cur"
+REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+       sys-libs/readline:=
+       units_cur? (
+               ${PYTHON_DEPS}
+               dev-python/future[${PYTHON_USEDEP}]
+       )
+"
+DEPEND="
+       ${RDEPEND}
+"
+
+pkg_setup() {
+       use units_cur && python-single-r1_pkg_setup
+}
+
+src_configure() {
+       econf ac_cv_path_PYTHON=no
+}
+
+src_compile() {
+       emake ${PN}
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       dodoc ChangeLog NEWS README
+
+       # we're intentionally delaying this since 'make install' would
+       # get confused if we shove 'units_cur' there, and there is no real
+       # need to add more complexity for it
+       if use units_cur; then
+               sed \
+                       -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+                       -e 's|^#!|&/usr/bin/python|g' \
+                       units_cur_inst > units_cur || die
+               python_fix_shebang units_cur
+               python_doscript units_cur
+       fi
+}