x11-base/xorg-server: +elogind defaults, relax REQUIRED_USE.
authorPiotr Karbowski <slashbeast@gentoo.org>
Thu, 21 Mar 2019 20:11:21 +0000 (21:11 +0100)
committerPiotr Karbowski <slashbeast@gentoo.org>
Thu, 21 Mar 2019 20:13:04 +0000 (21:13 +0100)
Changes after feedback on #gentoo-dev. Now elogind USE flag is enabled
by default, and !suid does not enforces elogind or systemd. !suid still
will work without any of those as long as login manager starts X as
root.

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
x11-base/xorg-server/xorg-server-1.20.4.ebuild
x11-base/xorg-server/xorg-server-9999.ebuild

index e5f0a8e00eee9fc060ba72fce880e92ce40c0933..d1fe2f091113245aa97849a680ed8b4ca1e57751 100644 (file)
@@ -15,7 +15,7 @@ if [[ ${PV} != 9999* ]]; then
 fi
 
 IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug elogind +glamor ipv6 libressl minimal selinux suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug +elogind +glamor ipv6 libressl minimal selinux suid systemd +udev unwind xcsecurity"
 
 CDEPEND=">=app-eselect/eselect-opengl-1.3.0
        !libressl? ( dev-libs/openssl:0= )
@@ -114,7 +114,7 @@ REQUIRED_USE="!minimal? (
                || ( ${IUSE_SERVERS} )
        )
        elogind? ( udev )
-       !suid? ( ^^ ( elogind systemd ) )
+       ?? ( elogind systemd )
        minimal? ( !glamor !wayland )
        xephyr? ( kdrive )"
 
index 37a691793700c1e4a2a26efa7340959e818280c9..3958ac822a37125aa5e08672423700d13cb2221b 100644 (file)
@@ -14,7 +14,7 @@ if [[ ${PV} != 9999* ]]; then
 fi
 
 IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug elogind +glamor ipv6 libressl minimal selinux suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug +elogind +glamor ipv6 libressl minimal selinux suid systemd +udev unwind xcsecurity"
 
 CDEPEND=">=app-eselect/eselect-opengl-1.3.0
        !libressl? ( dev-libs/openssl:0= )
@@ -113,7 +113,7 @@ REQUIRED_USE="!minimal? (
                || ( ${IUSE_SERVERS} )
        )
        elogind? ( udev )
-       !suid? ( ^^ ( elogind systemd ) )
+       ?? ( elogind systemd )
        minimal? ( !glamor !wayland )
        xephyr? ( kdrive )"