x11-terms/kitty: update live ebuild
authorPablo <pord@tuta.io>
Thu, 12 Mar 2020 00:17:29 +0000 (01:17 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 14 Mar 2020 12:06:55 +0000 (14:06 +0200)
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14931
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/kitty/files/kitty-9999-flags.patch [new file with mode: 0644]
x11-terms/kitty/kitty-9999.ebuild

diff --git a/x11-terms/kitty/files/kitty-9999-flags.patch b/x11-terms/kitty/files/kitty-9999-flags.patch
new file mode 100644 (file)
index 0000000..5a24767
--- /dev/null
@@ -0,0 +1,50 @@
+Respect user CFLAGS.
+
+--- a/setup.py
++++ b/setup.py
+@@ -236,7 +236,7 @@
+     if ccver >= (5, 0):
+         df += ' -Og'
+         float_conversion = '-Wfloat-conversion'
+     fortify_source = '-D_FORTIFY_SOURCE=2'
+-    optimize = df if debug or sanitize else '-O3'
++    optimize = ''
+     sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
+     cppflags_ = os.environ.get(
+         'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
+@@ -217,7 +217,7 @@
+     cflags = os.environ.get(
+         'OVERRIDE_CFLAGS', (
+             '-Wextra {} -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
+-            ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
++            ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
+         ).format(
+             float_conversion, std,
+             optimize,
+@@ -232,7 +232,7 @@
+     )
+     ldflags = os.environ.get(
+         'OVERRIDE_LDFLAGS',
+-        '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
++        '-Wall ' + ' '.join(sanitize_args)
+     )
+     ldflags = shlex.split(ldflags)
+     ldflags.append('-shared')
+@@ -614,7 +614,7 @@
+ def build_launcher(args, launcher_dir='.', bundle_type='source'):
+-    cflags = '-Wall -Werror -fpie'.split()
++    cflags = '-Wall -fpie'.split()
+     cppflags = []
+     libs = []
+     if args.profile or args.sanitize:
+@@ -626,8 +626,6 @@
+             cflags.append('-g')
+         if args.profile:
+             libs.append('-lprofiler')
+-    else:
+-        cflags.append('-O3')
+     if bundle_type.endswith('-freeze'):
+         cppflags.append('-DFOR_BUNDLE')
+         cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))
index c62b5d655696437279ef32deafac5c93f5ea7e25..684d939bff85bcdaa02e1bd65cb69a3d41968c83 100644 (file)
@@ -3,9 +3,9 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7,8} )
 
-inherit python-single-r1 toolchain-funcs xdg
+inherit eutils python-single-r1 toolchain-funcs xdg
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
@@ -38,7 +38,6 @@ RDEPEND="
        x11-libs/libXrandr
        sys-apps/dbus
        sys-libs/zlib
-       virtual/imagemagick-tools
        wayland? (
                dev-libs/wayland
                >=dev-libs/wayland-protocols-1.17
@@ -55,7 +54,7 @@ BDEPEND="virtual/pkgconfig"
 [[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
 
 PATCHES=(
-       "${FILESDIR}"/kitty-0.15.1-flags.patch
+       "${FILESDIR}"/kitty-9999-flags.patch
        "${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
 )
 
@@ -94,6 +93,7 @@ src_install() {
 
 pkg_postinst() {
        xdg_icon_cache_update
+       optfeature "Displaying images in the terminal" virtual/imagemagick-tools
 }
 
 pkg_postrm() {