dev-util/sysdig: Drop old
authorMichał Górny <mgorny@gentoo.org>
Sun, 8 Sep 2019 06:17:56 +0000 (08:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 8 Sep 2019 06:17:56 +0000 (08:17 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/sysdig/Manifest
dev-util/sysdig/sysdig-0.26.3.ebuild [deleted file]

index 1bc4bb1ee5ec494e8830640644bdf0d7d902f9a0..47171acfdc9d9bbe23520fdfebca8cc5f1a95699 100644 (file)
@@ -1,2 +1 @@
-DIST sysdig-0.26.3.tar.gz 902206 BLAKE2B ec25d0441c69b8c4c4fc431d073d2f93e476ece7add98412e54ce4286bcd7e32d4b1ff89f75dd728dc66c7d77da157bed2182bad85557c0dcec09648f86abb3d SHA512 f700d1ddae687a3474a8bf6816d2fef6c69e963a269a90a8362287dee698ac9799da18f01f383368c906d294ceb046160a8b0792292a72a3b08fc614b5b69d32
 DIST sysdig-0.26.4.tar.gz 902181 BLAKE2B a7ac38be2f7a3d7e4f4fdec6a2fbf5305a8224ee27352da70f509139ebefd14616f84c7b8860f50d2546819a94deb1117034bceddd22128fcf25386b835274f2 SHA512 f56f5d0a522b861df4803bfdafcaf8db3fc9c0e751d06c321082757f6828a210cb86bab4550a3b35bf6412f930e44ab0f5cf709a30651c57dd7064a68e273a88
diff --git a/dev-util/sysdig/sysdig-0.26.3.ebuild b/dev-util/sysdig/sysdig-0.26.3.ebuild
deleted file mode 100644 (file)
index 2d4c0de..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULES_OPTIONAL_USE=modules
-inherit linux-mod bash-completion-r1 cmake-utils
-
-DESCRIPTION="A system exploration and troubleshooting tool"
-HOMEPAGE="https://www.sysdig.org/"
-SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0
-       modules? ( || ( MIT GPL-2 ) )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="libressl +modules"
-
-RDEPEND="
-       app-misc/jq:0=
-       dev-cpp/tbb:0=
-       dev-lang/luajit:2=
-       >=dev-libs/jsoncpp-0.6_pre:0=
-       dev-libs/libb64:0=
-       dev-libs/protobuf:0=
-       net-dns/c-ares:0=
-       net-libs/grpc:0=
-       sys-libs/ncurses:0=
-       sys-libs/zlib:0=
-       libressl? ( dev-libs/libressl:0= )
-       !libressl? ( dev-libs/openssl:0= )
-       net-misc/curl:0="
-DEPEND="${RDEPEND}
-       app-arch/xz-utils
-       virtual/os-headers"
-
-# needed for the kernel module
-CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
-
-pkg_pretend() {
-       linux-mod_pkg_setup
-}
-
-pkg_setup() {
-       linux-mod_pkg_setup
-}
-
-src_prepare() {
-       sed -i -e 's:-ggdb::' CMakeLists.txt || die
-
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               # we will use linux-mod for that
-               -DBUILD_DRIVER=OFF
-               # libscap examples are not installed or really useful
-               -DBUILD_LIBSCAP_EXAMPLES=OFF
-
-               # unbundle the deps
-               -DUSE_BUNDLED_DEPS=OFF
-       )
-
-       cmake-utils_src_configure
-
-       # setup linux-mod ugliness
-       MODULE_NAMES="sysdig-probe(extra:${BUILD_DIR}/driver/src:)"
-       BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
-       BUILD_TARGETS="all"
-}
-
-src_compile() {
-       cmake-utils_src_compile
-       linux-mod_src_compile
-}
-
-src_install() {
-       cmake-utils_src_install
-       linux-mod_src_install
-
-       # remove sources
-       rm -r "${ED}"/usr/src || die
-
-       # move bashcomp to the proper location
-       dobashcomp "${ED}"/usr/etc/bash_completion.d/sysdig || die
-       rm -r "${ED}"/usr/etc || die
-}