app-text/xournalpp: Version bump
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 24 Apr 2020 21:09:54 +0000 (00:09 +0300)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Fri, 24 Apr 2020 21:10:10 +0000 (00:10 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
app-text/xournalpp/Manifest
app-text/xournalpp/xournalpp-1.0.18.ebuild [new file with mode: 0644]

index 24b899ea9990ee6c4360a771e401e9d798a77b42..02a9412a3935c18249007c154b1b804e17a1ed78 100644 (file)
@@ -1 +1,2 @@
 DIST xournalpp-1.0.17.tgz 14885382 BLAKE2B 501feb4480eee5aa38cc148f561d6c730505e43fd5d8017936f4b1d15f1b83ae936eb0a2e81b9889c668f9ed0a9c46b9053c984d45815c88829b023b7dbbd209 SHA512 cc3568ce22fd42f0e8458f1428c102d2fc18a9650d8c5968cadd6693fc19374780beb3c7f6206f2f494439296a883b2a5160da37e3a0e10d6fe3654084967ab9
+DIST xournalpp-1.0.18.tgz 14892343 BLAKE2B d2aaede0e85d724cf8032f38a6fa2c3c4862f26d410dbab8264dd50ab8ee0d26889eeab433ef615fe9ce271710192eca380ff80149431d5368125926cf8d2b25 SHA512 90568a2674a18ff711ecef5f1a66ea1c5746d7f1fde271b36342d9bf48e096e63075cf7fd8b69e39e144273a4d1b922c415eee929eba94b2fa515a0bb481815a
diff --git a/app-text/xournalpp/xournalpp-1.0.18.ebuild b/app-text/xournalpp/xournalpp-1.0.18.ebuild
new file mode 100644 (file)
index 0000000..6cb1258
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+       unset SRC_URI
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/xournalpp/xournalpp/archive/${PV}.tar.gz -> ${P}.tgz"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMONDEPEND="
+       app-text/poppler
+       dev-libs/glib
+       dev-libs/libxml2
+       dev-libs/libzip:=
+       media-libs/portaudio
+       media-libs/libsndfile
+       sys-libs/zlib:=
+       x11-libs/gtk+:3
+"
+RDEPEND="${COMMONDEPEND}
+"
+DEPEND="${COMMONDEPEND}
+"
+BDEPEND="
+       virtual/pkgconfig
+       sys-apps/lsb-release
+"
+
+src_prepare() {
+       cmake-utils_src_prepare
+}