games-strategy/0ad: Added missing header includes
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 12 Dec 2019 16:16:01 +0000 (17:16 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 12 Dec 2019 16:16:15 +0000 (17:16 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-strategy/0ad/0ad-0.0.23b_alpha.ebuild
games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch [new file with mode: 0644]

index 632db8344465a76ffd204fb9b174c2293875f60f..b059293c8f039a576d1c7fa81db3213df4b6c434 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -57,6 +57,7 @@ pkg_setup() {
 
 PATCHES=(
        "${FILESDIR}"/${PN}-0.0.21_alpha-gentoo.patch
+       "${FILESDIR}"/${PN}-0.0.23b-header_includes_fix.patch
 )
 
 src_configure() {
diff --git a/games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch b/games-strategy/0ad/files/0ad-0.0.23b-header_includes_fix.patch
new file mode 100644 (file)
index 0000000..60bf9d1
--- /dev/null
@@ -0,0 +1,20 @@
+--- 0ad-0.0.23b-alpha/source/ps/CLogger.h
++++ 0ad-0.0.23b-alpha/source/ps/CLogger.h
+@@ -22,6 +22,7 @@
+ #include <string>
+ #include <set>
+ #include <sstream>
++#include <deque>
+ #include "ps/ThreadUtil.h"
+ #include "third_party/cppformat/format.h"
+--- 0ad-0.0.23b-alpha/source/ps/Profiler2GPU.cpp
++++ 0ad-0.0.23b-alpha/source/ps/Profiler2GPU.cpp
+@@ -22,6 +22,7 @@
+ #include "precompiled.h"
++#include <stack>
+ #include "Profiler2GPU.h"
+ #include "lib/ogl.h"