sys-fs/zfs: update live ebuild
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Wed, 6 May 2020 03:02:47 +0000 (20:02 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Wed, 6 May 2020 03:03:14 +0000 (20:03 -0700)
unconditionally inherit autotools.eclass, so users can use
call eautoreconf call via portage hook if patching auto* files

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-fs/zfs/zfs-9999.ebuild

index 4f1011bcbb2e1df980efc046e227d41227e24c05..b712c747b662cbfd1a96a3949234b1a816027d86 100644 (file)
@@ -6,13 +6,13 @@ EAPI=7
 DISTUTILS_OPTIONAL=1
 PYTHON_COMPAT=( python3_{6,7} )
 
-inherit bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
+inherit autotools bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
 
 DESCRIPTION="Userland utilities for ZFS Linux kernel module"
 HOMEPAGE="https://github.com/openzfs/zfs"
 
 if [[ ${PV} == "9999" ]] ; then
-       inherit autotools git-r3 linux-mod
+       inherit git-r3 linux-mod
        EGIT_REPO_URI="https://github.com/openzfs/zfs.git"
 else
        SRC_URI="https://github.com/openzfs/${PN}/releases/download/${P}/${P}.tar.gz"