dev-ml/dns: update to opam.eclass
authorAlexis Ballier <aballier@gentoo.org>
Fri, 6 Oct 2017 13:19:22 +0000 (15:19 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 6 Oct 2017 13:21:11 +0000 (15:21 +0200)
Package-Manager: Portage-2.3.11, Repoman-2.3.3

dev-ml/dns/dns-1.0.0.ebuild

index 85d9d78a23c15954836e11cdd58393d3491d14ec..1780cf1361f407ab26946d514921afa7fc83fd81 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-inherit findlib eutils
+inherit findlib opam
 
 DESCRIPTION="A pure OCaml implementation of the DNS protocol"
 HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
@@ -15,7 +15,6 @@ KEYWORDS="~amd64"
 IUSE=""
 
 RDEPEND="
-       >=dev-lang/ocaml-4:=
        >=dev-ml/ocaml-base64-2.0.0:=
        >=dev-ml/ocaml-cstruct-3.0.2:=[ppx]
        dev-ml/ocaml-hashcons:=
@@ -27,7 +26,6 @@ RDEPEND="
 "
 DEPEND="
        dev-ml/jbuilder
-       dev-ml/opam
        ${RDEPEND}
 "
 
@@ -43,11 +41,3 @@ src_compile() {
 src_test() {
        jbuilder runtest -p dns || die
 }
-
-src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               dns.install || die
-}