games-fps/ut2004-bonuspack-cbp2: Fix SRC_URI, drop eclasses, EAPI 7
authorJames Le Cuirot <chewi@gentoo.org>
Thu, 24 Oct 2019 21:26:16 +0000 (22:26 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 27 Oct 2019 23:48:20 +0000 (23:48 +0000)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r2.ebuild [deleted file]
games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild [new file with mode: 0644]

diff --git a/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r2.ebuild b/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r2.ebuild
deleted file mode 100644 (file)
index d1d4cee..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MOD_DESC="Community Bonus Pack 2 Vol 1 and 2"
-MOD_NAME="Community Bonus Pack 2 Vol 1 and 2"
-
-inherit games games-mods
-
-HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2004"
-SRC_URI="https://ut.rushbase.net/beyondunreal/official/ut2004/cbp2-volume1_zip.zip
-       https://ut.rushbase.net/beyondunreal/official/ut2004/cbp2-volume2_zip.zip"
-
-LICENSE="freedist"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="games-fps/ut2004-bonuspack-cbp1
-       games-fps/ut2004-bonuspack-mega"
-
-src_prepare() {
-       # Provided by ut2004-bonuspack-cbp1
-       rm Music/Soeren.ogg
-       # Provided by ut2004-bonuspack-mega
-       rm Textures/Ty_RocketTextures.utx
-
-       cd Help
-       # Useless orphan file
-       rm Note.txt
-       mv GERROIDREADME.txt DOM-CBP2-Gerroid.txt
-       mv Readme.txt CBP2-Readme.txt
-}
diff --git a/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild b/games-fps/ut2004-bonuspack-cbp2/ut2004-bonuspack-cbp2-1-r3.ebuild
new file mode 100644 (file)
index 0000000..c14a79c
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="UT2004 Community Bonus Pack 2 Volume 1 and 2"
+HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2004"
+SRC_URI="https://ut2004.ut-files.com/BonusPacks/cbp2-volume1_zip.zip
+       https://ut2004.ut-files.com/BonusPacks/cbp2-volume2_zip.zip"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="|| ( games-fps/ut2004 >=games-server/ut2004-ded-3369.3-r2 )
+       games-fps/ut2004-bonuspack-cbp1
+       games-fps/ut2004-bonuspack-mega"
+
+S="${WORKDIR}"
+
+src_prepare() {
+       default
+
+       # In ut2004-bonuspack-cbp1.
+       rm Music/Soeren.ogg || die
+
+       # In ut2004-bonuspack-mega.
+       rm Textures/Ty_RocketTextures.utx || die
+
+       # Useless file.
+       rm Help/Note.txt || die
+
+       cd Help || die
+       mv Readme.txt CBP2-Readme.txt || die
+       mv GERROIDREADME.txt DOM-CBP2-Gerroid.txt || die
+       mv Tydal.txt DM-CBP2-Tydal.txt || die
+}
+
+src_install() {
+       insinto /opt/ut2004
+       doins -r *
+}