app-eselect/eselect-iptables-20200508: Version bump (bug #721578)
authorPatrick McLean <patrick.mclean@sony.com>
Sat, 9 May 2020 02:31:29 +0000 (19:31 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sat, 9 May 2020 02:54:50 +0000 (19:54 -0700)
Bug: https://bugs.gentoo.org/721578
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-eselect/eselect-iptables/Manifest
app-eselect/eselect-iptables/eselect-iptables-20200508.ebuild [new file with mode: 0644]

index f9fd8ed3b7b11ee1b2e213c8aebb27a50f90c82a..5f3cbd0b4f762bfab3e34f9b6d04d480e6c10c05 100644 (file)
@@ -1 +1,2 @@
 DIST eselect-iptables-20200319.tar.xz 1584 BLAKE2B be7cad34ef41a6b3c1b25470f2cef7bc2de33d83b5b0846a52695c0d09d9770368abd8d59a00a4edbc0ecbc91b83648de2e6686c7ee8a46036369558f5ed1e16 SHA512 828d8b0b1f41af2ad807c33f4e529411dc5feb21b37c76e8f19f0b7bf3d90ccb61db6b2e0b2ef353acfa4ea95b4a375da4fe769132b1fc6a7879acef6e10db9a
+DIST eselect-iptables-20200508.tar.xz 2152 BLAKE2B e28e566d15116134308ae122443dddb8e66bcbdbbe6f6448bab0b7061710cb3b5610a9f058f43c41c3b130150c5046a6b00b0697d28fea6f2c9049485486c3c4 SHA512 b76734a53a8d1a14e662758516e0bd6d5eefbf8bca5718dae67c912365e21aecc800d63ab9dee626807db8e065469d4019f9b5369937a5b123e25f91faa43d2e
diff --git a/app-eselect/eselect-iptables/eselect-iptables-20200508.ebuild b/app-eselect/eselect-iptables/eselect-iptables-20200508.ebuild
new file mode 100644 (file)
index 0000000..f033207
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manages the {,/usr}/sbin/iptables symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://dev.gentoo.org/~chutzpah/dist/iptables/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+       insinto /usr/share/eselect/modules
+       doins iptables.eselect
+
+       local symlink
+       for symlink in {eb,arp}tables; do
+               dosym iptables.eselect /usr/share/eselect/modules/${symlink}.eselect
+       done
+}