dev-ml/camlzip: Version bump to 1.10
authorTupone Alfredo <tupone@gentoo.org>
Mon, 17 Feb 2020 07:34:56 +0000 (08:34 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 17 Feb 2020 07:34:56 +0000 (08:34 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ml/camlzip/Manifest
dev-ml/camlzip/camlzip-1.10.ebuild [new file with mode: 0644]
dev-ml/camlzip/metadata.xml

index 7f733dd0ac0f813fc30b887425364437aeb1ad24..8b3dab8a648e0962f0863c8f64c2207c8fa9745e 100644 (file)
@@ -1,2 +1,3 @@
 DIST camlzip-1.06.tar.gz 26499 BLAKE2B a7a1dbe157c0dcb9847bcd6324bbb7cbaf39342d0fdbaed51d2c004ae7b03f8d655fb15da50dae6190b976675e405e28fa2d4fa35a2f4372c50519564d58f981 SHA512 5ef0172927106589620678897f12f054533503a5cf13df71bf4deda43f223d0cd6acce118977e87bce53afe289f367b851f192a8e693274c2bd13549121019dd
 DIST camlzip-1.07.tar.gz 26652 BLAKE2B f373ac0427faa9b6a846e9db8f3e48c00ec6885b8a11cc09fae96b5a7656908f172fda73dbea8ddd1b3dbfd98bcfa3e2e67ce9faf2942d1e260fc0a804813a05 SHA512 b92e9db002b9b398fd132c6ecd8098fac4cc7ddb3f770cc412990dcdf4bd62ba358c762d31fb0b5cd6b32f20d3bf4b3410ca6e86c511a438b92ece940f9831bd
+DIST camlzip-1.10.tar.gz 27335 BLAKE2B bbf24953634278589395dd9fcedf1e3becce8dad1f380393dc3ac59589143e1685dc14085ef566e12fb751c6f1a333dd368795a5083b94a43b71e058e86489f3 SHA512 5c42e0d808230e3820b2e7ef34b544ca51a7bf0a484ce4e1c8b1e4966133196bb3ff7c3ca85b9c50050aca389316eb52f0335f6e2ad60c000594a33171b9a9a9
diff --git a/dev-ml/camlzip/camlzip-1.10.ebuild b/dev-ml/camlzip/camlzip-1.10.ebuild
new file mode 100644 (file)
index 0000000..3c6a128
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="https://github.com/xavierleroy/camlzip"
+SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+
+SLOT="1/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]
+               >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+src_compile() {
+       emake all
+       if use ocamlopt; then
+               emake allopt
+       fi
+}
+
+src_install() {
+       findlib_src_preinst
+       emake DESTDIR="${D}" install-findlib
+       dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a
+
+       dodoc README Changes
+}
index 57e9234a0ba81ea9a475615ed973b47bb3678275..e9aafd4d0149eec50016d2d8e013e4f3c7877d97 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>tupone@gentoo.org</email>
+               <name>Tupone Alfredo</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">xavierleroy/camlzip</remote-id>
        </upstream>