x11-misc/lightdm-gtk-greeter: Migrate to 'appindicator' USE
authorPacho Ramos <pacho@gentoo.org>
Sat, 23 May 2020 10:04:33 +0000 (12:04 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 23 May 2020 10:04:33 +0000 (12:04 +0200)
Closes: https://bugs.gentoo.org/720318
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.6.ebuild
x11-misc/lightdm-gtk-greeter/lightdm-gtk-greeter-2.0.7-r1.ebuild

index fd4f5e0bfe13992251176f51d554debb1fb2792f..47ae408d044733e09a2309c6b51e4457f43c74f0 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -14,9 +14,9 @@ LICENSE="GPL-3 LGPL-3
        branding? ( CC-BY-3.0 )"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 ppc ppc64 x86"
-IUSE="ayatana branding"
+IUSE="appindicator branding"
 
-COMMON_DEPEND="ayatana? ( dev-libs/libindicator:3 )
+COMMON_DEPEND="appindicator? ( dev-libs/libindicator:3 )
        x11-libs/gtk+:3
        >=x11-misc/lightdm-1.2.2"
 
@@ -56,7 +56,7 @@ src_configure() {
        local myeconfargs=(
                --enable-kill-on-sigterm
                --enable-at-spi-command="${EPREFIX}/usr/libexec/at-spi-bus-launcher --launch-immediately"
-               $(use_enable ayatana libindicator)
+               $(use_enable appindicator libindicator)
        )
        econf "${myeconfargs[@]}"
 }
index f8a8dd980ea439ca270242f96e05d8fc6ccf096d..389baa1ee3b2c914cbdd5ea14b6fb7136b12a087 100644 (file)
@@ -14,9 +14,9 @@ LICENSE="GPL-3 LGPL-3
        branding? ( CC-BY-3.0 )"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ppc64 ~x86"
-IUSE="ayatana branding"
+IUSE="appindicator branding"
 
-COMMON_DEPEND="ayatana? ( dev-libs/libindicator:3 )
+COMMON_DEPEND="appindicator? ( dev-libs/libindicator:3 )
        x11-libs/gtk+:3
        >=x11-misc/lightdm-1.2.2"
 
@@ -60,7 +60,7 @@ src_configure() {
        local myeconfargs=(
                --enable-kill-on-sigterm
                --enable-at-spi-command="${EPREFIX}/usr/libexec/at-spi-bus-launcher --launch-immediately"
-               $(use_enable ayatana libindicator)
+               $(use_enable appindicator libindicator)
        )
        econf "${myeconfargs[@]}"
 }