sys-apps/s6: Add a static-libs USE flag
authorLuis Ressel <aranea@aixah.de>
Sun, 6 Mar 2016 22:14:03 +0000 (23:14 +0100)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 7 Mar 2016 22:32:51 +0000 (16:32 -0600)
libs6 is used by other packages such as s6-rc, so it'd be useful to be
able to control the availability of libs6.a without depending on
USE=static.

sys-apps/s6/s6-2.2.4.3.ebuild

index 171342f9a170cf4bdaf8b95dd85281baa55bec9f..8aeee3a383e0b3955646e7c524b58ea16e5ea973 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
 LICENSE="ISC"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="static"
+IUSE="static static-libs"
 
 DEPEND=">=sys-devel/make-4.0
        static? (
@@ -42,8 +42,8 @@ src_configure()
 {
        econf \
                $(use_enable !static shared) \
+               $(use_enable static-libs static) \
                $(use_enable static allstatic) \
-               $(use_enable static) \
                --bindir=/bin \
                --sbindir=/sbin \
                --dynlibdir=/$(get_libdir) \