app-antivirus/clamav: drop vulnerable wrt bug #681840
authorAaron Bauman <bman@gentoo.org>
Sat, 13 Apr 2019 03:56:05 +0000 (23:56 -0400)
committerAaron Bauman <bman@gentoo.org>
Sat, 13 Apr 2019 03:56:05 +0000 (23:56 -0400)
* cleanup metadata.xml

Signed-off-by: Aaron Bauman <bman@gentoo.org>
app-antivirus/clamav/Manifest
app-antivirus/clamav/clamav-0.100.1.ebuild [deleted file]
app-antivirus/clamav/metadata.xml

index f5e1e68075886ccf42f5a49b2bb475bc51d55b8e..3ef6b7e7d3597f17abcd9d98ebd79e65d85a45d8 100644 (file)
@@ -1,2 +1 @@
-DIST clamav-0.100.1.tar.gz 16154415 BLAKE2B df4ddde28b0b263765f4a571a407390b30aa6fe58d07e1b8fe427e70141219fb3d7c5addfbf30a350c6c08324dee1ec3dd80319306df7578ed87138c6513b99d SHA512 13a4e050e030ac3d1cc07b12bdd56c455e266e0b205a4c9bc9f18e53f6d8913a66eed2296abf857f395227ab0ed5c7bc90bc357bcb314dc9e18a9c6177dcc5b2
 DIST clamav-0.101.2.tar.gz 21722932 BLAKE2B 5c2960e678510a6f829fc9333e05a45a57a704e13eb407e0f890dd5553a1f9644eb3b1122c677755237b8c682127319d447a508087bc9130d14cd2cfec92896a SHA512 f9ea4589a8081acf7b6d454d1a068da05ae6574a9070a08f9438935795cb6dc084ffb9222b11fb1623f31962f859e6536a2f5bd1de29ef6b9b314efa5edc8c7e
diff --git a/app-antivirus/clamav/clamav-0.100.1.ebuild b/app-antivirus/clamav/clamav-0.100.1.ebuild
deleted file mode 100644 (file)
index 6d82802..0000000
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools eutils flag-o-matic user systemd
-
-DESCRIPTION="Clam Anti-Virus Scanner"
-HOMEPAGE="https://www.clamav.net/"
-SRC_URI="https://www.clamav.net/downloads/production/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* alpha"
-IUSE="bzip2 doc clamdtop iconv ipv6 libressl milter metadata-analysis-api selinux static-libs system-libmspack test uclibc"
-
-CDEPEND="bzip2? ( app-arch/bzip2 )
-       clamdtop? ( sys-libs/ncurses:0 )
-       iconv? ( virtual/libiconv )
-       metadata-analysis-api? ( dev-libs/json-c:= )
-       milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
-       >=sys-libs/zlib-1.2.2:=
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-devel/libtool
-       || ( dev-libs/libpcre2 >dev-libs/libpcre-6 )
-       system-libmspack? ( dev-libs/libmspack )
-       !!<app-antivirus/clamav-0.99"
-# hard block clamav < 0.99 due to linking problems Bug #567680
-# openssl is now *required* see this link as to why
-# https://blog.clamav.net/2014/02/introducing-openssl-as-dependency-to.html
-DEPEND="${CDEPEND}
-       virtual/pkgconfig
-       test? ( dev-libs/check )"
-RDEPEND="${CDEPEND}
-       selinux? ( sec-policy/selinux-clamav )"
-
-DOCS=( docs/clamdoc.pdf docs/phishsigs_howto.pdf docs/signatures.pdf )
-HTML_DOCS=( docs/html )
-
-PATCHES=(
-       "${FILESDIR}/clamav-0.100.0_autotools.patch"
-)
-
-pkg_setup() {
-       enewgroup clamav
-       enewuser clamav -1 -1 /dev/null clamav
-}
-
-src_prepare() {
-       default
-
-       eautoconf
-}
-
-src_configure() {
-       use ppc64 && append-flags -mminimal-toc
-       use uclibc && export ac_cv_type_error_t=yes
-
-       econf \
-               $(use_enable bzip2) \
-               $(use_enable clamdtop) \
-               $(use_enable ipv6) \
-               $(use_enable milter) \
-               $(use_enable static-libs static) \
-               $(use_enable test check) \
-               $(use_with iconv) \
-               $(use_with metadata-analysis-api libjson /usr) \
-               $(use_with system-libmspack) \
-               --cache-file="${S}"/config.cache \
-               --disable-experimental \
-               --disable-gcc-vcheck \
-               --disable-zlib-vcheck \
-               --enable-id-check \
-               --with-dbdir="${EPREFIX}"/var/lib/clamav \
-               --with-zlib="${EPREFIX}"/usr \
-               --disable-llvm
-}
-
-src_install() {
-       default
-
-       rm -rf "${ED}"/var/lib/clamav
-       newinitd "${FILESDIR}"/clamd.initd-r6 clamd
-       newconfd "${FILESDIR}"/clamd.conf-r1 clamd
-
-       systemd_dotmpfilesd "${FILESDIR}/tmpfiles.d/clamav.conf"
-       systemd_newunit "${FILESDIR}/clamd_at.service" "clamd@.service"
-       systemd_dounit "${FILESDIR}/clamd.service"
-       systemd_dounit "${FILESDIR}/freshclamd.service"
-
-       keepdir /var/lib/clamav
-       fowners clamav:clamav /var/lib/clamav
-       keepdir /var/log/clamav
-       fowners clamav:clamav /var/log/clamav
-
-       dodir /etc/logrotate.d
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/clamav.logrotate clamav
-
-       # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.pid:" \
-               -e "s:.*\(LocalSocket\) .*:\1 ${EPREFIX}/var/run/clamav/clamd.sock:" \
-               -e "s:.*\(User\) .*:\1 clamav:" \
-               -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamd.log:" \
-               -e "s:^\#\(LogTime\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/clamd.conf.sample || die
-       sed -i -e "s:^\(Example\):\# \1:" \
-               -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/freshclam.pid:" \
-               -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
-               -e "s:^\#\(UpdateLogFile\) .*:\1 ${EPREFIX}/var/log/clamav/freshclam.log:" \
-               -e "s:^\#\(NotifyClamd\).*:\1 ${EPREFIX}/etc/clamd.conf:" \
-               -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-               -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-               "${ED}"/etc/freshclam.conf.sample || die
-
-       if use milter ; then
-               # MilterSocket one to include ' /' because there is a 2nd line for
-               # inet: which we want to leave
-               ##dodoc "${FILESDIR}"/clamav-milter.README.gentoo
-               sed -i -e "s:^\(Example\):\# \1:" \
-                       -e "s:.*\(PidFile\) .*:\1 ${EPREFIX}/var/run/clamav/clamav-milter.pid:" \
-                       -e "s+^\#\(ClamdSocket\) .*+\1 unix:${EPREFIX}/var/run/clamav/clamd.sock+" \
-                       -e "s:.*\(User\) .*:\1 clamav:" \
-                       -e "s+^\#\(MilterSocket\) /.*+\1 unix:${EPREFIX}/var/run/clamav/clamav-milter.sock+" \
-                       -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
-                       -e "s:^\#\(LogFile\) .*:\1 ${EPREFIX}/var/log/clamav/clamav-milter.log:" \
-                       "${ED}"/etc/clamav-milter.conf.sample || die
-               cat >> "${ED}"/etc/conf.d/clamd <<-EOF
-                       MILTER_NICELEVEL=19
-                       START_MILTER=no
-               EOF
-
-               systemd_newunit "${FILESDIR}/clamav-milter.service-r1" clamav-milter.service
-       fi
-
-       if use doc; then
-          einstalldocs
-          doman docs/man/*.[1-8]
-       fi
-
-       for i in clamd freshclam clamav-milter
-       do
-               [[ -f "${D}"/etc/"${i}".conf.sample ]] && mv "${D}"/etc/"${i}".conf{.sample,}
-       done
-
-       prune_libtool_files --all
-}
-
-src_test() {
-       emake quick-check
-}
-
-pkg_postinst() {
-       if use milter ; then
-               elog "For simple instructions how to setup the clamav-milter read the"
-               elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
-       fi
-       if test -z $(find "${ROOT}"var/lib/clamav -maxdepth 1 -name 'main.c*' -print -quit) ; then
-               ewarn "You must run freshclam manually to populate the virus database files"
-               ewarn "before starting clamav for the first time.\n"
-       fi
-}
index e7a8dcd9494d06be0aefe3d23e7489cf27cfd8f9..7f16b5b6c6ecaa2660a71d42f5920a5797b4c493 100644 (file)
@@ -8,7 +8,6 @@
   <use>
     <flag name="clamdtop">A Top like tool which shows what clamd is currently scanning amongst other things</flag>
     <flag name="metadata-analysis-api">Enables collection of file property metadata using ClamAV API for analysis by ClamAV bytecode programs.</flag>
-    <flag name="system-libmspack">Use system libmspack instead of built in</flag>
     <flag name="xml">DMG and XAR support</flag>
   </use>
   <upstream>