app-laptop/mbpfan: bump to 2.1.1
authorGöktürk Yüksek <gokturk@gentoo.org>
Mon, 29 Apr 2019 14:52:37 +0000 (10:52 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Mon, 29 Apr 2019 14:53:42 +0000 (10:53 -0400)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
app-laptop/mbpfan/Manifest
app-laptop/mbpfan/mbpfan-2.1.1.ebuild [new file with mode: 0644]

index 36ed6c5008bb60fc98c63de27c3f8bd7707f528c..0af7c168aa49f2a2357b339cf3711e2f6f4dea2f 100644 (file)
@@ -2,3 +2,4 @@ DIST mbpfan-1.9.1.tar.gz 24393 BLAKE2B 9fd96f6903aa360a86e2813d9bf3e57fe28dacc7b
 DIST mbpfan-2.0.0.tar.gz 37912 BLAKE2B 8d2ce41d8f6a724e28ace0c23047dde4a0a60ae10beeec3e3d7194bbd6b87ae0c340cf025deca896208e225083e0bb67043c6b00135544f2d78e39fbf55b3fcd SHA512 9a7f930afe0a151fe50bf3ef1a06a5cecaced0c47f7088a83b91e25dff85d4b0d53494eac5eb1b624bde6ff1d3307a0d9fe6ba392fdacbe58e241d93d11cda6d
 DIST mbpfan-2.0.1.tar.gz 37805 BLAKE2B 0988a9b5cd359b4e64fdb1e63322dea7582fdc9a9dda0760550945282ef6142dbcab8aeb78ec1a725b5f9aebcda72386e3fa4b8b5f7ecdf078106d229fb7e2af SHA512 8fd2e37b9b81720ff7efa490d285da5980ef5dcc858fef4b0c24166a8f0df46aa230ea18fca5775b222271918e5ca6df1bfbbdced068182c20eeb86192ed2019
 DIST mbpfan-2.1.0.tar.gz 39303 BLAKE2B b51b7df8c24cc49561f45614a655c698b85f149367f888aceb90b90e27e2da03ede7beed58e552e163e9f625d950290198f6d56a545c10989a8d0e27909556a7 SHA512 8750ac47419e84f8692a478e3977b56b98be9e255d5be9876094eef0f86bc587510959cc4cff0d681fb9e1ecaf98f90d9d0b63a1a6ddd25e8de4ccfda747b54a
+DIST mbpfan-2.1.1.tar.gz 40637 BLAKE2B bdd17a9a883cc9af3cb7d55a2c8594c435fb367f0c6b5dec2b3da85747e2c2af591ed1dabf082cbbc31ac92ce5b2dc5194d8a50836c87cd784f238322ab09d9f SHA512 c1bf81c5e2f2f4f710a8455c65f10dc2dc2255319a7dbf4367c31884eece8d9909d28f3a00e5fc4d964d65254b36202a2a2b666d0ef04ea04153baded6039449
diff --git a/app-laptop/mbpfan/mbpfan-2.1.1.ebuild b/app-laptop/mbpfan/mbpfan-2.1.1.ebuild
new file mode 100644 (file)
index 0000000..9a83fb1
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+if [[ "${PV}" = 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}
+
+src_install() {
+       emake DESTDIR="${ED}" install
+
+       # Remove the empty systemd unit directory
+       # It doesn't actually install the unit file
+       rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+       # Actually install the sytstemd unit file
+       systemd_dounit ${PN}.service
+       # Install openrc init file
+       newinitd ${PN}.init.gentoo ${PN}
+
+       # make install doesn't install the docs in the right place
+       rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+
+       einstalldocs
+}