dev-ml/zarith: Version bump to 1.9.1
authorTupone Alfredo <tupone@gentoo.org>
Mon, 17 Feb 2020 18:19:53 +0000 (19:19 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Mon, 17 Feb 2020 18:19:53 +0000 (19:19 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ml/zarith/Manifest
dev-ml/zarith/zarith-1.9.1.ebuild [new file with mode: 0644]

index 01222184fdaa97a98e80793581ef868520bd59ef..ebd41f16d4fb1617666d1dca9d5ce8d9c9eef721 100644 (file)
@@ -2,3 +2,4 @@ DIST zarith-1.4.1.tgz 88831 BLAKE2B f1a434f61dfa23cdb1e41d3e84c53444832978d119aa
 DIST zarith-1.5.tar.gz 89211 BLAKE2B f84127baeaf7efb61957e3657e7f2e3771df974ff6f92e3e0a04c93550ee48d5fa9adf473e423d409a2f40dba568ced30ef903c790f32b6e8bccd1032a475b84 SHA512 4e616b8cc81cd83f51696926e598be3bcda0bb5999db3cf42dd627cf537320a0216c74eb14c57e57fc21c909df8ef3fb3fa602a7ad633c115d2ee61af5a9fdcd
 DIST zarith-1.6.tar.gz 89353 BLAKE2B 4dc7dbe17426a57929632d38fae91bdfec4f54371ebb0ae55b6d88c7fffb47c229d0800125eaa2f5fca4e096bb50dceb4e0851ef88a16d3e89bc1db7b9cb32b9 SHA512 a12eacfaa809885f2b0f09ed0fc56d90ebaf9a3d8685db8a41dcaaaa2a9d2410ec96529d8bee653343ea8d51304861dbcf12daba06206a6cf07753ad3b09780d
 DIST zarith-1.7.tar.gz 89617 BLAKE2B ee8a272a7421d9e723af8aa6207da8fe046585804e669058b6dec8fb47cab80e438d0520c1b61ed6c79bc279d162a7a1043fa40e74c50342b7e4d553ca8e8f5b SHA512 812b5f9b24ce7a24d3370b8728ff6eeb56e3280fa1573e694fe54e781668c29bf8ff95e94aeff59df948adc85b8acd6b4efe117fb50a124f19b4227bee78e753
+DIST zarith-1.9.1.tar.gz 92321 BLAKE2B d61def81600cb5f3ae931eabebcdf081b6025dd24b1deae46a55f5db4f2c67d44b38b9cb9d73fc7fd9bd76c81545294373e3df5969da217209079a2912a8e285 SHA512 e77620c66a59d35811acfc45c7ef3f0d50d3042194654b1f5b652a2ed5fb9d5f88e9173222e5ced286c61854434da05a4d96668089faa66ff2917afa677fc32f
diff --git a/dev-ml/zarith/zarith-1.9.1.ebuild b/dev-ml/zarith/zarith-1.9.1.ebuild
new file mode 100644 (file)
index 0000000..dc83db4
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib multilib
+
+DESCRIPTION="Arithmetic and logic operations over arbitrary-precision integers"
+HOMEPAGE="https://github.com/ocaml/Zarith"
+SRC_URI="https://github.com/ocaml/Zarith/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc mpir +ocamlopt"
+
+RDEPEND="
+       >=dev-lang/ocaml-4:=[ocamlopt?]
+       !mpir? ( dev-libs/gmp:0= )
+       mpir? ( sci-libs/mpir )"
+
+DEPEND="${RDEPEND} dev-lang/perl"
+DOCS=( README.md Changes )
+
+S="${WORKDIR}/Zarith-release-${PV}"
+
+src_configure() {
+       tc-export CC
+       ./configure -host "${CHOST}" \
+               -ocamllibdir /usr/$(get_libdir)/ocaml \
+               -installdir "${ED}"/usr/$(get_libdir)/ocaml \
+               $(usex mpir "-mpir" "-gmp") || die
+}
+
+src_compile() {
+       emake -j 1 HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) all
+       use doc && emake doc
+}
+
+src_test() {
+       if use ocamlopt ; then
+               emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
+       else
+               ewarn "Tests require USE=ocamlopt. Skipping them."
+       fi
+}
+
+src_install() {
+       findlib_src_preinst
+       emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) install
+       dosym zarith/libzarith.a /usr/$(get_libdir)/ocaml/libzarith.a
+       use doc && HTML_DOCS=( html/* )
+       einstalldocs
+}