app-emacs/nxml-gentoo-schemas: Version bump to 20200229.
authorUlrich Müller <ulm@gentoo.org>
Sat, 29 Feb 2020 16:16:55 +0000 (17:16 +0100)
committerUlrich Müller <ulm@gentoo.org>
Sat, 29 Feb 2020 16:17:31 +0000 (17:17 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/nxml-gentoo-schemas/Manifest
app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20200229.ebuild [new file with mode: 0644]

index 54bcebdfade2fff85b4a3780412cbaefdf92f0bc..2174ff9580559fcbc86f481b34da8b20e16d7fd3 100644 (file)
@@ -1,2 +1,3 @@
 DIST nxml-gentoo-schemas-20180611.tar.xz 11572 BLAKE2B e8a573e79d9531d676b8c52ba9c2869f765e6bb0326f3f00c99dd3ecfd19af6eaedbb06ddf84ae541690962a5e67b87726d6cc90a3bf7dd6d805b5c2c96b6321 SHA512 8473233141a56935e41a9d0371501f3fe055b21600746db29e14ec91d12a43da595e500a876eea8cdddd885358df0825055143e901eb599a2fcbac7147a04fa8
 DIST nxml-gentoo-schemas-20200109.tar.xz 8672 BLAKE2B 8b27e334e0d4aa6d7ca2d85dfacf320fbc6f8ce6d801c2f0c8a12991b7346a8d9f6977d5071b409bdd059e29209130deb90a36556c58d1f98fad55e92e2be7bc SHA512 afbe78b4323ca6cd7a0f5855f0c29e65caed7f6587378cee66da284e3782035fea59171bd28dcd402ffbb65fbcb9261e4a2ed2abfd41b05d6581ae29f6852519
+DIST nxml-gentoo-schemas-20200229.tar.xz 8448 BLAKE2B 2883821546f9243491fd88d56cce6e2acd87de8650cfb8ec4cca25b44cfc2465e521f3ae5d00ed0c7e6d0c8b4785e7e08a43990ac48a178fda036ca3e805be88 SHA512 8c587e19b80fc766989e09d255a3f349c35e373b44607b757b7594dfb4daef0ac11d5724a43f1672226b8922b07112f076649d83e1eb6623012b320653f5c815
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20200229.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20200229.ebuild
new file mode 100644 (file)
index 0000000..51c686f
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+       insinto "${SITEETC}/${PN}"
+       doins schemas.xml *.rnc
+       elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}