dev-libs/clhpp: New package for Khronos OpenCL C++ bindings.
authorJan Vesely <jano.vesely@gmail.com>
Thu, 25 Apr 2019 22:25:05 +0000 (18:25 -0400)
committerMatt Turner <mattst88@gentoo.org>
Fri, 26 Apr 2019 18:08:40 +0000 (11:08 -0700)
Headers only.
Add Khronos-CLHPP license.
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11827
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/clhpp/Manifest [new file with mode: 0644]
dev-libs/clhpp/clhpp-2.0.10.ebuild [new file with mode: 0644]
dev-libs/clhpp/metadata.xml [new file with mode: 0644]
licenses/Khronos-CLHPP [new file with mode: 0644]

diff --git a/dev-libs/clhpp/Manifest b/dev-libs/clhpp/Manifest
new file mode 100644 (file)
index 0000000..a7469db
--- /dev/null
@@ -0,0 +1 @@
+DIST clhpp-2.0.10.tar.gz 129954 BLAKE2B 1beb9b41ce1ad8ec88d0ccfa5f1d7a7af931841fa64d79b9eb9db90538f1b43f3cee5c74dc015ba835ee4ded2e926967bc3aa00dcc6ec0f5b65a04f9618ea1a9 SHA512 4a4898540c55422ca0cc6ba7f0c5495b915fc34df50f8add90e7f06dd5ef1d01a767234ecdee3757292980aa2f938e773177bcc73f28ac9c1b42d386863dea58
diff --git a/dev-libs/clhpp/clhpp-2.0.10.ebuild b/dev-libs/clhpp/clhpp-2.0.10.ebuild
new file mode 100644 (file)
index 0000000..dcea074
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+DESCRIPTION="Khronos OpenCL C++ bindings"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP/"
+SRC_URI="https://github.com/KhronosGroup/OpenCL-CLHPP/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Khronos-CLHPP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+inherit python-any-r1 cmake-utils
+
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_unpack() {
+       unpack ${A}
+       # create symlink to change name
+       ln -s OpenCL-CLHPP-${PV} ${P}
+}
+
+src_prepare() {
+       # User patches + QA
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/include"
+               -DBUILD_DOCS=OFF
+               -DBUILD_EXAMPLES=OFF
+               -DBUILD_TESTS=OFF
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+}
+
+src_install() {
+       cmake-utils_src_install
+}
diff --git a/dev-libs/clhpp/metadata.xml b/dev-libs/clhpp/metadata.xml
new file mode 100644 (file)
index 0000000..61f4288
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>x11@gentoo.org</email>
+       <name>X11</name>
+</maintainer>
+<longdescription lang="en">
+Khronos (tm) provided headers for C++ bindings for OpenCL.
+</longdescription>
+</pkgmetadata>
diff --git a/licenses/Khronos-CLHPP b/licenses/Khronos-CLHPP
new file mode 100644 (file)
index 0000000..5c0255a
--- /dev/null
@@ -0,0 +1,25 @@
+Copyright (c) 2008-2015 The Khronos Group Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and/or associated documentation files (the
+"Materials"), to deal in the Materials without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Materials, and to
+permit persons to whom the Materials are furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Materials.
+
+MODIFICATIONS TO THIS FILE MAY MEAN IT NO LONGER ACCURATELY REFLECTS
+KHRONOS STANDARDS. THE UNMODIFIED, NORMATIVE VERSIONS OF KHRONOS
+SPECIFICATIONS AND HEADER INFORMATION ARE LOCATED AT
+    https://www.khronos.org/registry/
+
+THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.