dev-ml/opam: Remove old
authorAlexis Ballier <aballier@gentoo.org>
Wed, 2 Aug 2017 10:37:19 +0000 (12:37 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 2 Aug 2017 11:22:48 +0000 (13:22 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-ml/opam/Manifest
dev-ml/opam/files/cmdl.patch [deleted file]
dev-ml/opam/opam-1.3.0.ebuild [deleted file]

index cdd3845a4be767a24dda164d94413cb7c5f385ad..242fc63bf742dbe9498317a4ad50559c18d29d61 100644 (file)
@@ -1,2 +1 @@
-DIST opam-1.3.0.tar.gz 669389 SHA256 9d50122940f44401c2dcee39b12a4e4afea851b2f2ab47d90b522f7395f10f7a SHA512 290535a1bb2e7eff6ab44126c5070d2bed94e68cee3bd5e47054f91ad81ed92e9a21f7888bd1dafcb397e3ac61589d4eaf7267305ac63d1aee08761701bdf647 WHIRLPOOL 64b8fc334b8dd193af1d4ae0d0bb445554f6afeb3007fefd4048816d1bd90363c7b18c4d44521da8162bc3ae49668d26b75ef811a4de4d5287597024d0b74ddd
 DIST opam-1.3.1.tar.gz 669485 SHA256 625767c3465219cc8799aad1449c74279b31686db0821300cfdb92fbff17e9fd SHA512 d075c9b2c9670d712f29bd2df34b8020da52041fa2bbef599cb54a81f63554507d78bebece45ecf668d3d1d4ed514e4ab88a1d86b64088d283bca7a8e75ae582 WHIRLPOOL 8fcddf18056503b2010e8377175c5af87b098cec977fbedabcafc4178817b780bd538ae672600f5a7bdca423c99aefab24a7341f17e40465a9f3e1f1c3324623
diff --git a/dev-ml/opam/files/cmdl.patch b/dev-ml/opam/files/cmdl.patch
deleted file mode 100644 (file)
index 5a05808..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-Backport of:
-
-commit b8c8b94e9f642e52ca0cd1f8b125606b9ef13b78
-Author: Daniel Bünzli <daniel.buenzli@erratique.ch>
-Date:   Wed Feb 8 15:07:13 2017 +0100
-
-    Avoid name clash with next version of cmdliner.
-
-
-Index: opam-1.3.0/src/client/opamArg.ml
-===================================================================
---- opam-1.3.0.orig/src/client/opamArg.ml
-+++ opam-1.3.0/src/client/opamArg.ml
-@@ -436,9 +436,9 @@ let mk_flag ?section flags doc =
-   let doc = Arg.info ?docs:section ~doc flags in
-   Arg.(value & flag & doc)
--let mk_opt ?section ?vopt flags value doc conv default =
-+let mk_opt ?section ?vopt flags value doc kind default =
-   let doc = Arg.info ?docs:section ~docv:value ~doc flags in
--  Arg.(value & opt ?vopt conv default & doc)
-+  Arg.(value & opt ?vopt kind default & doc)
- let mk_tristate_opt ?section flags value doc =
-   let doc = Arg.info ?docs:section ~docv:value ~doc flags in
-@@ -510,13 +510,13 @@ let term_info title ~doc ~man =
-   let man = man @ help_sections in
-   Term.info ~sdocs:global_option_section ~docs:"COMMANDS" ~doc ~man title
--let arg_list name doc conv =
-+let arg_list name doc kind =
-   let doc = Arg.info ~docv:name ~doc [] in
--  Arg.(value & pos_all conv [] & doc)
-+  Arg.(value & pos_all kind [] & doc)
--let nonempty_arg_list name doc conv =
-+let nonempty_arg_list name doc kind =
-   let doc = Arg.info ~docv:name ~doc [] in
--  Arg.(non_empty & pos_all conv [] & doc)
-+  Arg.(non_empty & pos_all kind [] & doc)
- (* Common flags *)
- let print_short_flag =
diff --git a/dev-ml/opam/opam-1.3.0.ebuild b/dev-ml/opam/opam-1.3.0.ebuild
deleted file mode 100644 (file)
index 40e4425..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="A source-based package manager for OCaml"
-HOMEPAGE="http://opam.ocaml.org/"
-LICENSE="LGPL-3-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~ppc"
-IUSE=""
-
-if [[ ${PV} != 9999 ]]; then
-       SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-else
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/ocaml/opam.git"
-fi
-
-DEPEND="dev-lang/ocaml:=
-       || ( net-misc/wget net-misc/curl )
-       dev-ml/extlib:=
-       dev-ml/ocaml-re:=
-       dev-ml/ocamlgraph:=
-       dev-ml/cmdliner:=
-       dev-ml/cudf:=
-       >=dev-ml/dose3-5:=
-       dev-ml/uutf:=
-       dev-ml/jsonm:=
-"
-RDEPEND="${DEPEND}
-       dev-ml/findlib
-"
-
-src_prepare() {
-       epatch "${FILESDIR}/cmdl.patch"
-}
-
-src_compile() {
-       emake -j1
-       cd doc
-       emake man
-}
-
-src_test() {
-       EMAIL=foo@bar.com emake -j1 tests
-}
-
-src_install() {
-       default
-       emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
-}