mate-extra/mate-utils: Fix #709976
authorAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 22:14:04 +0000 (18:14 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 22:14:36 +0000 (18:14 -0400)
Closes: https://bugs.gentoo.org/709976
Package-Manager: Portage-2.3.96, Repoman-2.3.21
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
mate-extra/mate-utils/files/mate-utils-1.22.2-gcc-10-fno-common.patch [new file with mode: 0644]
mate-extra/mate-utils/mate-utils-1.22.2-r1.ebuild [moved from mate-extra/mate-utils/mate-utils-1.22.2.ebuild with 95% similarity]

diff --git a/mate-extra/mate-utils/files/mate-utils-1.22.2-gcc-10-fno-common.patch b/mate-extra/mate-utils/files/mate-utils-1.22.2-gcc-10-fno-common.patch
new file mode 100644 (file)
index 0000000..052c1a2
--- /dev/null
@@ -0,0 +1,37 @@
+From d2d4902a68b8eabf4dc26a8ba49019e5ea6040c6 Mon Sep 17 00:00:00 2001
+From: rbuj <robert.buj@gmail.com>
+Date: Wed, 29 Jan 2020 16:22:09 +0100
+Subject: [PATCH] Fix build using gcc 10 -fno-common flag
+
+Closes #258
+---
+ baobab/src/baobab.c | 2 ++
+ baobab/src/baobab.h | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/baobab/src/baobab.c b/baobab/src/baobab.c
+index 07af1a1d..d4edde1f 100644
+--- a/baobab/src/baobab.c
++++ b/baobab/src/baobab.c
+@@ -42,6 +42,8 @@
+ static void push_iter_in_stack (GtkTreeIter *);
+ static GtkTreeIter pop_iter_from_stack (void);
++BaobabApplication baobab;
++
+ static gint currentdepth = 0;
+ static GtkTreeIter currentiter;
+ static GtkTreeIter firstiter;
+diff --git a/baobab/src/baobab.h b/baobab/src/baobab.h
+index b8d01817..76b22d6a 100644
+--- a/baobab/src/baobab.h
++++ b/baobab/src/baobab.h
+@@ -99,7 +99,7 @@ struct _BaobabApplication {
+ };
+ /* Application singleton */
+-BaobabApplication baobab;
++extern BaobabApplication baobab;
+ struct chan_data {
+       guint64 size;
similarity index 95%
rename from mate-extra/mate-utils/mate-utils-1.22.2.ebuild
rename to mate-extra/mate-utils/mate-utils-1.22.2-r1.ebuild
index e739dfd98991364230fb799bbfd7d56d6bbba591..63022e807b7bec4df5b6cb7a6d5bcd3623cad454 100644 (file)
@@ -46,6 +46,10 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        x11-base/xorg-proto"
 
+PATCHES=(
+       "${FILESDIR}/${P}-gcc-10-fno-common.patch"
+)
+
 src_prepare() {
        # Make apps visible in all DEs.
        LC_ALL=C find . -iname '*.desktop.in*' -exec \