app-portage/g-cpan: change to create dirs for portage user/group
authorSergiy Borodych <Sergiy.Borodych@gmail.com>
Wed, 27 Apr 2016 13:01:40 +0000 (16:01 +0300)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 30 Apr 2016 16:56:12 +0000 (18:56 +0200)
this is allow to use g-cpan users besides root more easely,
just add users into portage group and do not fix permissions every install

app-portage/g-cpan/g-cpan-9999.ebuild

index 1d1c113c9dd97607563a2bf81aa0dfdca2a3940d..1ff7291fd259993f51e31704381e559996f43d4a 100644 (file)
@@ -32,15 +32,15 @@ RDEPEND="${DEPEND}
 
 src_install() {
                perl-module_src_install
-               diropts "-m0755"
+               diropts -m0775 -o portage -g portage
                dodir "/var/tmp/g-cpan"
                dodir "/var/log/g-cpan"
                keepdir "/var/log/g-cpan"
 }
 
 pkg_postinst() {
-       elog "You may wish to adjust the permissions on /var/tmp/g-cpan"
-       elog "if you have users besides root expecting to use g-cpan."
+       elog "If you want to use g-cpan besides root you may wish to"
+       elog " adjust the permissions on /var/tmp/g-cpan or add users into portage group."
        elog "Please note that some CPAN packages need additional manual"
        elog "parameters or tweaking, due to bugs in their build systems."
 }