media-radio/xastir: Drop old
authorThomas Beierlein <tomjbe@gentoo.org>
Sat, 8 Feb 2020 07:28:01 +0000 (08:28 +0100)
committerThomas Beierlein <tomjbe@gentoo.org>
Sat, 8 Feb 2020 07:29:17 +0000 (08:29 +0100)
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
media-radio/xastir/Manifest
media-radio/xastir/files/xastir-2.0.4-fortify.diff [deleted file]
media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff [deleted file]
media-radio/xastir/files/xastir-2.0.8-no-builtin-shapelib.diff [deleted file]
media-radio/xastir/files/xastir-2.0.8-scripts.diff [deleted file]
media-radio/xastir/metadata.xml
media-radio/xastir/xastir-2.0.8-r1.ebuild [deleted file]

index 6fd1281880ef4e854b2affddea92905c39791fca..48be224f00bae541c1512805edac12ac34c03fcc 100644 (file)
@@ -1,2 +1 @@
-DIST xastir-2.0.8.tar.gz 2697256 BLAKE2B 12a12219885d7923e3262494ac39b7b7f200118953b1e47ae25917f3f1732a1cff931de06462de7d5f1216c9b61561f8090fc49e18b40380eaa58b3559c5f123 SHA512 fd98a880392e9fcb049c6049ebc6a6a5e600571b7b59fd7061a72404abd68530ae6f152c9eabdc39be0458b33b363ce7fa3fdd5330003298bca8eaac62a6982f
 DIST xastir-2.1.4.tar.gz 2694124 BLAKE2B 90fd8ef340fc5bad43c9501c6530dcd4bd60eaab9c04638c68f80add46f0df24c45db334549915edaee95cbdcc9b7580d6343d81d84cb819f4ef5a76c9f79242 SHA512 e96f9de52499615cfe88708656d111d417e0d0e08f798b2d97f6a270db3e639c4fb5219767f8fd399fe75f51f02391ace87ae7175ae9a44cb5a4056ab7b573b1
diff --git a/media-radio/xastir/files/xastir-2.0.4-fortify.diff b/media-radio/xastir/files/xastir-2.0.4-fortify.diff
deleted file mode 100644 (file)
index e2c34b0..0000000
+++ /dev/null
@@ -1,144 +0,0 @@
---- src/rac_data.c.orig        2012-09-23 18:19:22.000000000 +0200
-+++ src/rac_data.c     2012-11-29 21:00:53.000000000 +0100
-@@ -212,7 +212,8 @@
-     char char_offset[16];
-     char index[32];
-     int found = 0;
--    rac_record racdata;
-+    char buffer[sizeof(rac_record)];
-+    rac_record *racdata = (rac_record *)buffer;
-     /*char        filler[8];*/
-     char amacall_path[MAX_VALUE];
-@@ -220,7 +221,7 @@
-     xastir_snprintf(index, sizeof(index)," ");
--    xastir_snprintf(racdata.callsign, sizeof(racdata.callsign)," ");
-+    xastir_snprintf(racdata->callsign, sizeof(racdata->callsign)," ");
-     /* ====================================================================    */
-     /*    Search thru the index, get the RBA                */
-@@ -257,19 +258,19 @@
-         if (callsign[5] == '-')
-             (void)chomp(callsign,5);
--        while (!feof(fdb) && strncmp((char *)&racdata, callsign, 6) < 0)
-+        while (!feof(fdb) && strncmp(buffer, callsign, 6) < 0)
- //WE7U
- // Problem here:  We're sticking 8 bytes too many into racdata!
--            rc = fgets((char *)&racdata, sizeof(racdata), fdb);
-+            rc = fgets(buffer, sizeof(buffer), fdb);
-     } else
-         fprintf(stderr,"Search:Could not open RAC data base: %s\n", get_data_base_dir("fcc/AMACALL.LST") );
-     /*  || (callsign[5] == '-' && strncmp((char *)&racdata,callsign,5) < 0)) */
--    (void)chomp(racdata.callsign, 6);
-+    (void)chomp(racdata->callsign, 6);
--    if (!strncmp((char *)racdata.callsign, callsign, 6)) {
-+    if (!strncmp(racdata->callsign, callsign, 6)) {
-         found = 1;
- // Some of these cause problems on 64-bit processors, so commented
-@@ -293,82 +294,82 @@
-         xastir_snprintf(data->callsign,
-             sizeof(data->callsign),
-             "%s",
--            racdata.callsign);
-+            racdata->callsign);
-         xastir_snprintf(data->first_name,
-             sizeof(data->first_name),
-             "%s",
--            racdata.first_name);
-+            racdata->first_name);
-  
-         xastir_snprintf(data->last_name,
-             sizeof(data->last_name),
-             "%s",
--            racdata.last_name);
-+            racdata->last_name);
-  
-         xastir_snprintf(data->address,
-             sizeof(data->address),
-             "%s",
--            racdata.address);
-+            racdata->address);
-  
-         xastir_snprintf(data->city,
-             sizeof(data->city),
-             "%s",
--            racdata.city);
-+            racdata->city);
-  
-         xastir_snprintf(data->province,
-             sizeof(data->province),
-             "%s",
--            racdata.province);
-+            racdata->province);
-  
-         xastir_snprintf(data->postal_code,
-             sizeof(data->postal_code),
-             "%s",
--            racdata.postal_code);
-+            racdata->postal_code);
-  
-         xastir_snprintf(data->qual_a,
-             sizeof(data->qual_a),
-             "%s",
--            racdata.qual_a);
-+            racdata->qual_a);
-  
-         xastir_snprintf(data->qual_b,
-             sizeof(data->qual_b),
-             "%s",
--            racdata.qual_b);
-+            racdata->qual_b);
-  
-         xastir_snprintf(data->qual_c,
-             sizeof(data->qual_c),
-             "%s",
--            racdata.qual_c);
-+            racdata->qual_c);
-  
-         xastir_snprintf(data->qual_d,
-             sizeof(data->qual_d),
-             "%s",
--            racdata.qual_d);
-+            racdata->qual_d);
-  
-         xastir_snprintf(data->club_name,
-             sizeof(data->club_name),
-             "%s",
--            racdata.club_name);
-+            racdata->club_name);
-  
-         xastir_snprintf(data->club_address,
-             sizeof(data->club_address),
-             "%s",
--            racdata.club_address);
-+            racdata->club_address);
-  
-         xastir_snprintf(data->club_city,
-             sizeof(data->club_city),
-             "%s",
--            racdata.club_city);
-+            racdata->club_city);
-  
-         xastir_snprintf(data->club_province,
-             sizeof(data->club_province),
-             "%s",
--            racdata.club_province);
-+            racdata->club_province);
-  
-         xastir_snprintf(data->club_postal_code,
-             sizeof(data->club_postal_code),
-             "%s",
--            racdata.club_postal_code);
-+            racdata->club_postal_code);
-  
-     }
-     (void)fclose(fdb);
diff --git a/media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff b/media-radio/xastir/files/xastir-2.0.8-fix-graphicsmagick.diff
deleted file mode 100644 (file)
index 8919239..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# backported from xastir-2.1.4 (see bug #688444)
---- a/src/map_geo.c    2019-07-26 15:54:19.534488550 +0200
-+++ b/src/map_geo.c    2019-07-26 15:56:47.779713950 +0200
-@@ -125,20 +125,7 @@
- #undef PACKAGE_TARNAME
- #define XASTIR_PACKAGE_VERSION PACKAGE_VERSION
- #undef PACKAGE_VERSION
--#ifdef HAVE_GRAPHICSMAGICK
--/*#include <GraphicsMagick/magick/api.h>*/
--/* Define MAGICK_IMPLEMENTATION to access private interfaces
-- * such as DestroyImagePixels(). This may not be a good thing,
-- * but DestroyImagePixels() has been in this code for a long
-- * time. Defining MAGIC_IMPLEMENTATION eliminates the warning that is
-- * now (9/28/2010) being seen on some distros (Ubuntu 10.04 and
-- * OpenSuSE-11.3)
-- */
--#define MAGICK_IMPLEMENTATION
- #include <magick/api.h>
--#else   // HAVE_GRAPHICSMAGICK
--#include <magick/api.h>
--#endif  // HAVE_GRAPHICSMAGICK
- #undef PACKAGE_BUGREPORT
- #define PACKAGE_BUGREPORT XASTIR_PACKAGE_BUGREPORT
- #undef XASTIR_PACKAGE_BUGREPORT
-@@ -2030,7 +2017,6 @@
-             if (!SyncImagePixels(image))
-                 fprintf(stderr, "SyncImagePixels Failed....\n");
-       }
--        DestroyImagePixels(image);
-     }
-     // If were are drawing to a low bpp display (typically < 8bpp)
diff --git a/media-radio/xastir/files/xastir-2.0.8-no-builtin-shapelib.diff b/media-radio/xastir/files/xastir-2.0.8-no-builtin-shapelib.diff
deleted file mode 100644 (file)
index 8cbdbc2..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
---- configure.ac.orig  2016-07-12 07:08:17.988160777 +0200
-+++ configure.ac       2016-07-12 07:11:42.591138389 +0200
-@@ -382,27 +382,17 @@
- # Check for Shapelib
- use_shapelib=yes
--force_internal_shapelib=no
- shapelib_desired=yes
- LIBSHP=""
- SUBSHP=""
- # This symbol will be blank if the proj library hasn't been found, and will
- # have the three programs that need proj if it has
- CONTSHP=""
--AC_ARG_WITH(internal-shapelib,[  --with-internal-shapelib  Force use of internal shapelib library.],force_internal_shapelib=$withval)
- AC_ARG_WITH(shapelib,[  --without-shapelib        Disable shapelib features.],shapelib_desired=$withval)
- if test "${shapelib_desired}" = "no"; then
-   use_shapelib=no
--  force_internal_shapelib=no
- fi
--if test "${force_internal_shapelib}" = "yes"; then
--  AC_MSG_WARN([***************************************************************** ])  
--  AC_MSG_WARN([Internal Shapelib library has been forced.                        ])
--  AC_MSG_WARN([***************************************************************** ])
--  # Temporary setting to get into if block below
--  use_shapelib=no
--fi
--if test "${shapelib_desired}" = "yes" -a "${force_internal_shapelib}" = "no"; then
-+if test "${shapelib_desired}" = "yes" ; then
-   use_shapelib=no
-   AC_CHECK_HEADERS(shapefil.h libshp/shapefil.h, [AC_CHECK_LIB(shp, DBFOpen, use_shapelib=yes
-     LIBS="$LIBS -lshp"
-@@ -411,26 +401,6 @@
-     AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
-     break)])
- fi
--if test "${shapelib_desired}" = "yes" -a "${use_shapelib}" = "no"; then
-- AC_MSG_WARN([**************************************************************** ])  
-- AC_MSG_WARN([Your system does not have shapelib installed.  Using an internal ])
-- AC_MSG_WARN([version.  This may lead to a larger filesize for the executable. ])
-- AC_MSG_WARN([Install shapelib on your system to eliminate this warning.       ])
-- AC_MSG_WARN([**************************************************************** ])  
-- LIBSHP="-Lshapelib -lshape"
-- CPPFLAGS="-I\$(top_srcdir)/src/shapelib $CPPFLAGS"
-- SUBSHP="shapelib" 
-- use_shapelib=yes
-- force_internal_shapelib=yes
-- AC_DEFINE(HAVE_DBFGETFIELDINDEX, , Define to 1 if your `shp' library has DBFGetFieldIndex. ) 
-- AC_DEFINE(HAVE_LIBSHP, , Define to 1 if you have the `shp' library (-lshp). )
-- AC_DEFINE(HAVE_SHAPEFIL_H, , Define to 1 if you have the `shapefil.h' header. )
--
-- if  test  $use_proj = "yes" 
-- then
--   CONTSHP="shpcentrd$(EXEEXT) shpproj$(EXEEXT) shpdata$(EXEEXT) shpwkb$(EXEEXT)"
-- fi
--fi
- AC_SUBST(SUBSHP)
- AC_SUBST(CONTSHP)
- AC_SUBST(LIBSHP)
diff --git a/media-radio/xastir/files/xastir-2.0.8-scripts.diff b/media-radio/xastir/files/xastir-2.0.8-scripts.diff
deleted file mode 100644 (file)
index 35c7324..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-# patch scripts location (bug #407185). partially backported from upstream.
---- xastir-2.0.0-orig/scripts/Makefile.am.orig 2012-11-27 05:41:23.000000000 +0100
-+++ xastir-2.0.0/scripts/Makefile.am   2012-12-05 06:21:59.000000000 +0100
-@@ -43,10 +41,8 @@
-     values \
-     values.pl \
-     waypoint-get.pl \
--    xastir-fixcfg.sh \
--    xastir-migrate.sh \
-     Xastir_tigerpoly.py
- install-data-hook:
-       cd $(DESTDIR)$(scriptsdir) && \
--      chmod a+x *.sh *.pl *.py get-* gpx2* *.bash
-+      chmod a+x *.pl *.py get-* gpx2* *.bash
-diff -Nur -u xastir-2.0.0.orig/scripts/coord-convert.pl xastir-2.0.0/scripts/coord-convert.pl
---- xastir-2.0.0.orig/scripts/coord-convert.pl 2010-07-03 22:09:48.000000000 +0000
-+++ xastir-2.0.0/scripts/coord-convert.pl      2012-03-07 15:46:01.000000000 +0000
-@@ -26,7 +26,7 @@
- #
--use lib "${prefix}/lib";
-+use lib /usr/share/xastir/scripts;
- use Coordinate;         # WE7U's Coordinate.pm module
-diff -Nur -u xastir-2.0.0.orig/scripts/permutations.pl xastir-2.0.0/scripts/permutations.pl
---- xastir-2.0.0.orig/scripts/permutations.pl  2010-07-03 22:09:48.000000000 +0000
-+++ xastir-2.0.0/scripts/permutations.pl       2012-03-07 15:42:34.000000000 +0000
-@@ -34,7 +34,7 @@
- #
--use lib "/usr/local/lib";
-+use lib "/usr/share/xastir/scripts";
- use Coordinate;         # WE7U's Coordinate.pm module
-diff -Nur -u xastir-2.0.0.orig/scripts/test_coord.pl xastir-2.0.0/scripts/test_coord.pl
---- xastir-2.0.0.orig/scripts/test_coord.pl    2010-01-31 02:12:23.000000000 +0000
-+++ xastir-2.0.0/scripts/test_coord.pl 2012-03-07 15:42:34.000000000 +0000
-@@ -33,7 +33,7 @@
- #------------------------------------------------------------------------------------------------
--use lib "/usr/local/lib";
-+use lib "/usr/share/xastir/scripts";
- use Coordinate;               # Snag WE7U's Coordinate module
-diff -Nur -u xastir-2.0.0.orig/scripts/toporama250k.pl xastir-2.0.0/scripts/toporama250k.pl
---- xastir-2.0.0.orig/scripts/toporama250k.pl  2010-01-31 02:12:23.000000000 +0000
-+++ xastir-2.0.0/scripts/toporama250k.pl       2012-03-07 15:46:49.000000000 +0000
-@@ -28,14 +28,14 @@
- # map files for the whole of Canada!
- #
- #
--# - "cd /usr/local/share/xastir/maps"
-+# - "cd /usr/share/xastir/maps"
- #
- # - Assure you have write privileges in the directory above either
- #   by becoming root using the "su" command, using "sudo", or
- #   temporarily changing ownership and/or privileges on the
- #   "maps" directory.
- #
--# - "/usr/local/lib/xastir/toporama250k.pl"
-+# - "/usr/share/xastir/scripts/toporama250k.pl"
- #
- # - The script will create/populate this directory heirarchy:
- #   .../maps/toporama/images/
-diff -Nur -u xastir-2.0.0.orig/scripts/toporama50k.pl xastir-2.0.0/scripts/toporama50k.pl
---- xastir-2.0.0.orig/scripts/toporama50k.pl   2010-01-31 02:12:23.000000000 +0000
-+++ xastir-2.0.0/scripts/toporama50k.pl        2012-03-07 15:47:01.000000000 +0000
-@@ -27,14 +27,14 @@
- # map files for the whole of Canada!
- #
- #
--# - "cd /usr/local/share/xastir/maps"
-+# - "cd /usr/share/xastir/maps"
- #
- # - Assure you have write privileges in the directory above either
- #   by becoming root using the "su" command, using "sudo", or
- #   temporarily changing ownership and/or privileges on the
- #   "maps" directory.
- #
--# - "/usr/local/lib/xastir/toporama50k.pl"
-+# - "/usr/share/xastir/scripts/toporama50k.pl"
- #
- # - The script will create/populate this directory heirarchy:
- #   .../maps/toporama/images/
index e44c45094ca1eb099a7605de99c5d7d49c248768..f7dfda2f708478fe02da73bccf58470ce77344bc 100644 (file)
@@ -6,7 +6,6 @@
                <name>Thomas Beierlein</name>
        </maintainer>
        <use>
-               <flag name="gdal">Support for some further map formats</flag>
                <flag name="geotiff">Install geotiff support. Allows using USGS DRG topo
                        maps or other types of geotiff mapes/images</flag>
        </use>
diff --git a/media-radio/xastir/xastir-2.0.8-r1.ebuild b/media-radio/xastir/xastir-2.0.8-r1.ebuild
deleted file mode 100644 (file)
index 4d12a2c..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="X Amateur Station Tracking and Information Reporting"
-HOMEPAGE="http://xastir.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gdal geotiff +graphicsmagick"
-
-DEPEND=">=x11-libs/motif-2.3:0
-       x11-libs/libXt
-       x11-libs/libX11
-       x11-libs/libXpm
-       x11-apps/xfontsel
-       dev-libs/libpcre
-       net-misc/curl
-       sys-libs/db:4.8
-       sci-libs/shapelib
-       !graphicsmagick? ( <media-gfx/imagemagick-7:0=[-hdri,-q32] )
-       graphicsmagick? ( media-gfx/graphicsmagick:=[-q32] )
-       geotiff? ( sci-libs/proj
-               sci-libs/libgeotiff
-               media-libs/tiff:0 )
-       gdal? ( sci-libs/gdal )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # fix script location (bug #407185)
-       epatch "${FILESDIR}"/${P}-scripts.diff
-
-       # fix __FORTIFY_SOURCE warning (bug #337365)
-       epatch "${FILESDIR}"/${PN}-2.0.4-fortify.diff
-
-       # do not use builtin shapelib if sci-libs/shapelib is not installed
-       # instead build without shapelib support (bug #430704)
-       epatch "${FILESDIR}"/${P}-no-builtin-shapelib.diff
-
-       # do not filter duplicate flags (see bug 411095)
-       epatch "${FILESDIR}"/${PN}-2.0.0-dont-filter-flags.diff
-
-       # fix compile problem with newer graphicsmagic
-       epatch "${FILESDIR}"/${PN}-2.0.8-fix-graphicsmagick.diff
-
-       eautoreconf
-}
-
-src_configure() {
-       # provide include path to GraphicsMagic for configure stage
-       use graphicsmagick && append-cflags -I/usr/include/GraphicsMagick
-       econf --with-pcre \
-               --with-shapelib \
-               --with-dbfawk \
-               --without-ax25 \
-               --without-festival \
-               --without-gpsman \
-               $(use_with !graphicsmagick imagemagick) \
-               $(use_with graphicsmagick) \
-               $(use_with geotiff libproj) \
-               $(use_with geotiff) \
-               $(use_with gdal)
-}
-
-src_compile() {
-       emake AR="$(tc-getAR)"
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       rm -rf "${D}"/usr/share/doc/${PN}
-       dodoc AUTHORS ChangeLog FAQ README README.Contributing \
-               README.Getting-Started README.MAPS
-}
-
-pkg_postinst() {
-       elog "Kernel mode AX.25 and GPSman library not supported."
-       elog
-       elog "Remember you have to be root to add addditional scripts,"
-       elog "maps and other configuration data under /usr/share/xastir."
-}