dev-java/openjdk: bump to 11.0.7_p10
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 21 Apr 2020 17:42:54 +0000 (10:42 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 21 Apr 2020 20:26:23 +0000 (13:26 -0700)
Bug: https://bugs.gentoo.org/713180
Bug: https://bugs.gentoo.org/718720
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk/Manifest
dev-java/openjdk/openjdk-11.0.7_p10.ebuild [new file with mode: 0644]

index 011f214901acd6133f3c23dbc1ebb0e6deed85cc..eb7d4c53c251a68330704a8f16350417f3df258f 100644 (file)
@@ -1,4 +1,5 @@
 DIST openjdk-11.0.6.tar.bz2 90755968 BLAKE2B 5bf23cc107ffae4cfc82be4f9b4b17de57575ee13e8fd461027e319a441c89c65fc852affb89f98a54307fa865ed5cdfb216809c6196866b31dfaa7011ad3d57 SHA512 d2296556c947c46883c16df3c1b7d809e6987dd6fd1a2667333e1245049560f3da744f6a51609a918cd9c509316b01160de2c080d5b9d3ed1af0b312dcbc575e
+DIST openjdk-11.0.7_p10.tar.bz2 91317054 BLAKE2B 113f6d0b1ea97aa6c3a619a3f4183b72f5e0448422d17b6ffc4d778ce50eee68e4495d610845d1f3aace2e5660703dad96583203c6d12b5528e0f33f78df7cec SHA512 c6776bd05e2cbb42134ccf5cd522e4b73d1662e3cf136a8718c5d302b9c44e76b74a554b81aa14c5deda20bee76abc80a144f5c2e1941b70c9503579c325aa12
 DIST openjdk-8.242.tar.bz2 452896 BLAKE2B 73176533ad62942f9a9547378aa5547a5f064076d24be527d0fb8b13c30a48680957bca731ee54771cae66e78f8800995426431ec266f0c61330a573efaacc23 SHA512 2a98dcead63b8e5dc6db841416b16c12a84f557c8efa6272bc4dc125333de1e20ab83050d1ee441a77f78b47b2c52dbc7d29810ce562218129eff29a5c79daca
 DIST openjdk-8.252_p09.tar.bz2 454656 BLAKE2B 7132af72a09da9ded1759ccf92da6237a24e3fd15209b8d5aecb7011b890cd3484b4724f6b6a144e4bc5cb41931076985f75a9089c178938be62ac1a1d2a7f07 SHA512 0f03f1549dea1577cb01895d4e34721d16443977c5e7b3f0744af9cf2c0b09e60cb6d91b35a5e474c593d518d5610fb4c14fc4b9a907a7e13bb2351cea51bd06
 DIST openjdk-corba-8.242.tar.bz2 1033721 BLAKE2B 5e0cee4d5b8faa0e940ed096f807ef231ce7c10b180ac89d5faf9ae276bab1044ca1ae6e826490e9d66f17ebd55026c17e7675a62dd4bf633cecfa3390944f97 SHA512 cf2cefcb590b7a1c637b709ce9f59c56a5354f90a3095726c3168962f4808ccb27a82909234343f510ad90dda56b83c934fa9ccb788ddf0f66e60c65b06d8e84
diff --git a/dev-java/openjdk/openjdk-11.0.7_p10.ebuild b/dev-java/openjdk/openjdk-11.0.7_p10.ebuild
new file mode 100644 (file)
index 0000000..9df2e6c
--- /dev/null
@@ -0,0 +1,274 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools check-reqs flag-o-matic java-pkg-2 java-vm-2 multiprocessing pax-utils toolchain-funcs
+
+# we need -ga tag to fetch tarball and unpack it, but exact number everywhere else to
+# set build version properly
+MY_PV="${PV%_p*}-ga"
+SLOT="${MY_PV%%[.+]*}"
+
+DESCRIPTION="Open source implementation of the Java programming language"
+HOMEPAGE="https://openjdk.java.net"
+SRC_URI="https://hg.${PN}.java.net/jdk-updates/jdk${SLOT}u/archive/jdk-${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+
+IUSE="alsa cups debug doc examples gentoo-vm headless-awt javafx +jbootstrap nsplugin +pch selinux source systemtap webstart"
+
+COMMON_DEPEND="
+       media-libs/freetype:2=
+       media-libs/giflib:0/7
+       media-libs/libpng:0=
+       media-libs/lcms:2=
+       sys-libs/zlib
+       virtual/jpeg:0=
+       systemtap? ( dev-util/systemtap )
+"
+
+# Many libs are required to build, but not to run, make is possible to remove
+# by listing conditionally in RDEPEND unconditionally in DEPEND
+RDEPEND="
+       ${COMMON_DEPEND}
+       >=sys-apps/baselayout-java-0.1.0-r1
+       !headless-awt? (
+               x11-libs/libX11
+               x11-libs/libXext
+               x11-libs/libXi
+               x11-libs/libXrandr
+               x11-libs/libXrender
+               x11-libs/libXt
+               x11-libs/libXtst
+       )
+       alsa? ( media-libs/alsa-lib )
+       cups? ( net-print/cups )
+       selinux? ( sec-policy/selinux-java )
+"
+
+DEPEND="
+       ${COMMON_DEPEND}
+       app-arch/zip
+       media-libs/alsa-lib
+       net-print/cups
+       x11-base/xorg-proto
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libXt
+       x11-libs/libXtst
+       javafx? ( dev-java/openjfx:${SLOT}= )
+       || (
+               dev-java/openjdk-bin:${SLOT}
+               dev-java/openjdk:${SLOT}
+       )
+"
+
+PDEPEND="
+       webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
+       nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )
+"
+
+REQUIRED_USE="javafx? ( alsa !headless-awt )"
+
+S="${WORKDIR}/jdk${SLOT}u-jdk-${MY_PV}"
+
+# The space required to build varies wildly depending on USE flags,
+# ranging from 2GB to 16GB. This function is certainly not exact but
+# should be close enough to be useful.
+openjdk_check_requirements() {
+       local M
+       M=2048
+       M=$(( $(usex jbootstrap 2 1) * $M ))
+       M=$(( $(usex debug 3 1) * $M ))
+       M=$(( $(usex doc 320 0) + $(usex source 128 0) + 192 + $M ))
+
+       CHECKREQS_DISK_BUILD=${M}M check-reqs_pkg_${EBUILD_PHASE}
+}
+
+pkg_pretend() {
+       openjdk_check_requirements
+       has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+}
+
+pkg_setup() {
+       openjdk_check_requirements
+       java-vm-2_pkg_setup
+
+       JAVA_PKG_WANT_BUILD_VM="openjdk-${SLOT} openjdk-bin-${SLOT}"
+       JAVA_PKG_WANT_SOURCE="${SLOT}"
+       JAVA_PKG_WANT_TARGET="${SLOT}"
+
+       # The nastiness below is necessary while the gentoo-vm USE flag is
+       # masked. First we call java-pkg-2_pkg_setup if it looks like the
+       # flag was unmasked against one of the possible build VMs. If not,
+       # we try finding one of them in their expected locations. This would
+       # have been slightly less messy if openjdk-bin had been installed to
+       # /opt/${PN}-${SLOT} or if there was a mechanism to install a VM env
+       # file but disable it so that it would not normally be selectable.
+
+       local vm
+       for vm in ${JAVA_PKG_WANT_BUILD_VM}; do
+               if [[ -d ${EPREFIX}/usr/lib/jvm/${vm} ]]; then
+                       java-pkg-2_pkg_setup
+                       return
+               fi
+       done
+
+       if has_version --host-root dev-java/openjdk:${SLOT}; then
+               export JDK_HOME=${EPREFIX}/usr/$(get_libdir)/openjdk-${SLOT}
+       else
+               if [[ ${MERGE_TYPE} != "binary" ]]; then
+                       JDK_HOME=$(best_version --host-root dev-java/openjdk-bin:${SLOT})
+                       [[ -n ${JDK_HOME} ]] || die "Build VM not found!"
+                       JDK_HOME=${JDK_HOME#*/}
+                       JDK_HOME=${EPREFIX}/opt/${JDK_HOME%-r*}
+                       export JDK_HOME
+               fi
+       fi
+}
+
+src_prepare() {
+       default
+       chmod +x configure || die
+}
+
+src_configure() {
+       # Work around stack alignment issue, bug #647954. in case we ever have x86
+       use x86 && append-flags -mincoming-stack-boundary=2
+
+       # Work around -fno-common ( GCC10 default ), bug #713180
+       append-flags -fcommon
+
+       # Enabling full docs appears to break doc building. If not
+       # explicitly disabled, the flag will get auto-enabled if pandoc and
+       # graphviz are detected. pandoc has loads of dependencies anyway.
+
+       local myconf=(
+               --disable-ccache
+               --enable-full-docs=no
+               --with-boot-jdk="${JDK_HOME}"
+               --with-extra-cflags="${CFLAGS}"
+               --with-extra-cxxflags="${CXXFLAGS}"
+               --with-extra-ldflags="${LDFLAGS}"
+               --with-giflib=system
+               --with-lcms=system
+               --with-libjpeg=system
+               --with-libpng=system
+               --with-native-debug-symbols=$(usex debug internal none)
+               --with-vendor-name="Gentoo"
+               --with-vendor-url="https://gentoo.org"
+               --with-vendor-bug-url="https://bugs.gentoo.org"
+               --with-vendor-vm-bug-url="https://bugs.openjdk.java.net"
+               --with-vendor-version-string="${PVR}"
+               --with-version-pre=""
+               --with-version-string="${PV%_p*}"
+               --with-version-build="${PV#*_p}"
+               --with-zlib=system
+               --enable-dtrace=$(usex systemtap yes no)
+               --enable-headless-only=$(usex headless-awt yes no)
+       )
+
+       if use javafx; then
+               local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+               if [[ -r ${zip} ]]; then
+                       myconf+=( --with-import-modules="${zip}" )
+               else
+                       die "${zip} not found or not readable"
+               fi
+       fi
+
+       # PaX breaks pch, bug #601016
+       if use pch && ! host-is-pax; then
+               myconf+=( --enable-precompiled-headers )
+       else
+               myconf+=( --disable-precompiled-headers )
+       fi
+
+       (
+               unset _JAVA_OPTIONS JAVA JAVA_TOOL_OPTIONS JAVAC XARGS
+               CFLAGS= CXXFLAGS= LDFLAGS= \
+               CONFIG_SITE=/dev/null \
+               econf "${myconf[@]}"
+       )
+}
+
+src_compile() {
+       local myemakeargs=(
+               JOBS=$(makeopts_jobs)
+               LOG=debug
+               CFLAGS_WARNINGS_ARE_ERRORS= # No -Werror
+               $(usex doc docs '')
+               $(usex jbootstrap bootcycle-images product-images)
+       )
+       emake "${myemakeargs[@]}" -j1 #nowarn
+}
+
+src_install() {
+       local dest="/usr/$(get_libdir)/${PN}-${SLOT}"
+       local ddest="${ED}${dest#/}"
+
+       cd "${S}"/build/*-release/images/jdk || die
+
+       # Create files used as storage for system preferences.
+       mkdir .systemPrefs || die
+       touch .systemPrefs/.system.lock || die
+       touch .systemPrefs/.systemRootModFile || die
+
+       # Oracle and IcedTea have libjsoundalsa.so depending on
+       # libasound.so.2 but OpenJDK only has libjsound.so. Weird.
+       if ! use alsa ; then
+               rm -v lib/libjsound.* || die
+       fi
+
+       if ! use examples ; then
+               rm -vr demo/ || die
+       fi
+
+       if ! use source ; then
+               rm -v lib/src.zip || die
+       fi
+
+       rm -v lib/security/cacerts || die
+
+       dodir "${dest}"
+       cp -pPR * "${ddest}" || die
+
+       dosym ../../../../../etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
+       # must be done before running itself
+       java-vm_set-pax-markings "${ddest}"
+
+       einfo "Creating the Class Data Sharing archives and disabling usage tracking"
+       "${ddest}/bin/java" -server -Xshare:dump -Djdk.disableLastUsageTracking || die
+
+       use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+       java-vm_revdep-mask
+       java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+
+       if use doc ; then
+               docinto html
+               dodoc -r "${S}"/build/*-release/images/docs/*
+               dosym ../../../usr/share/doc/"${PF}" /usr/share/doc/"${PN}-${SLOT}"
+       fi
+}
+
+pkg_postinst() {
+       java-vm-2_pkg_postinst
+
+       if use gentoo-vm ; then
+               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
+               ewarn "recognised by the system. This will almost certainly break"
+               ewarn "many java ebuilds as they are not ready for openjdk-11"
+       else
+               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
+               ewarn "will not be recognised by the system. For example, simply calling"
+               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+               ewarn "fully supports Java ${SLOT}. This JDK must therefore be invoked using its"
+               ewarn "absolute location under ${EPREFIX}/usr/$(get_libdir)/${PN}-${SLOT}."
+       fi
+}