mail-mta/exim-4.93.0.4-r1: add patch to fix compilation using -fno-common
authorFabian Groffen <grobian@gentoo.org>
Sun, 24 May 2020 11:26:24 +0000 (13:26 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sun, 24 May 2020 11:26:54 +0000 (13:26 +0200)
Closes: https://bugs.gentoo.org/723430
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
mail-mta/exim/exim-4.93.0.4-r1.ebuild
mail-mta/exim/files/exim-4.93-fno-common.patch [new file with mode: 0644]

index cb68569b7c8438c0ed30e5ec7b555a383f872203..19d13cef361f60b46390a2a29776f8f51450e8da 100644 (file)
@@ -116,6 +116,7 @@ src_prepare() {
        eapply     "${FILESDIR}"/exim-4.93-localscan_dlopen.patch
        eapply -p2 "${FILESDIR}"/exim-4.93-radius.patch # 720364
        eapply     "${FILESDIR}"/exim-4.93-CVE-2020-12783.patch # 722484
+       eapply     "${FILESDIR}"/exim-4.93-fno-common.patch # 723430
 
        if use maildir ; then
                eapply "${FILESDIR}"/exim-4.20-maildir.patch
diff --git a/mail-mta/exim/files/exim-4.93-fno-common.patch b/mail-mta/exim/files/exim-4.93-fno-common.patch
new file mode 100644 (file)
index 0000000..c5fff1c
--- /dev/null
@@ -0,0 +1,16 @@
+Fix -fno-common linking
+
+Bug: https://bugs.gentoo.org/723430
+Bug: https://bugs.exim.org/show_bug.cgi?id=2577
+
+--- exim-4.93.0.4/src/globals.h
++++ exim-4.93.0.4/src/globals.h
+@@ -342,7 +342,7 @@
+ extern BOOL    allow_domain_literals;  /* As it says */
+ extern BOOL    allow_mx_to_ip;         /* Allow MX records to -> ip address */
+ #ifdef EXPERIMENTAL_ARC
+-struct arc_set *arc_received;        /* highest ARC instance evaluation struct */
++extern struct arc_set *arc_received;         /* highest ARC instance evaluation struct */
+ extern int     arc_received_instance;  /* highest ARC instance number in headers */
+ extern int     arc_oldest_pass;        /* lowest passing instance number in headers */
+ extern const uschar *arc_state;              /* verification state */