games-strategy/colobot: Fix build failure due to missing include
authorMichał Górny <mgorny@gentoo.org>
Thu, 14 May 2020 08:55:11 +0000 (10:55 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 14 May 2020 10:19:09 +0000 (12:19 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-strategy/colobot/colobot-0.1.12.ebuild
games-strategy/colobot/files/colobot-0.1.12-includes.patch [new file with mode: 0644]

index 1611ef4a1d61fdb96b93ec61097463bf3e69bf44..7f53954e401765221628bc7520fce304b30fd9bc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -37,6 +37,11 @@ DEPEND="
 RDEPEND="${DEPEND}
        games-strategy/colobot-data"
 
+PATCHES=(
+       # https://github.com/colobot/colobot/pull/1300
+       "${FILESDIR}"/${P}-includes.patch
+)
+
 src_prepare() {
        cmake-utils_src_prepare
 
diff --git a/games-strategy/colobot/files/colobot-0.1.12-includes.patch b/games-strategy/colobot/files/colobot-0.1.12-includes.patch
new file mode 100644 (file)
index 0000000..1fb3a27
--- /dev/null
@@ -0,0 +1,23 @@
+From 2cfab017938e1cf44f633647eec2ccc2ed1da38b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 14 May 2020 10:35:01 +0200
+Subject: [PATCH] Fix missing <limits> include
+
+Add missing <limits> include for std::numeric_limits.  This fixes
+build failure after boost stopped implicitly including it for us.
+---
+ src/script/script.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/script/script.h b/src/script/script.h
+index bc64dc232..dd4e02ff4 100644
+--- a/src/script/script.h
++++ b/src/script/script.h
+@@ -27,6 +27,7 @@
+ #include "CBot/CBot.h"
+ #include <memory>
++#include <limits>
+ #include <string>
+ #include <boost/optional.hpp>