net-mail/notmuch: Bump version
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Sun, 27 Oct 2019 19:11:46 +0000 (19:11 +0000)
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Sun, 27 Oct 2019 19:12:22 +0000 (19:12 +0000)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
net-mail/notmuch/Manifest
net-mail/notmuch/notmuch-0.29.2.ebuild [new file with mode: 0644]

index 88efb8a8c36e3d4a87797b90dee4d131bb72f1e1..5fccb1523e7fc936bfbb85fb17cf9bf1dc8eb32c 100644 (file)
@@ -1,3 +1,4 @@
 DIST database-v1.tar.xz 204876 BLAKE2B 846a8d2f17edb61ed1c3d3c655becd1f60b4046772058706f13d516f65421a5105593660f1c556907bb2bb9607a3c2521243d1be07bffb70817ad3b8461680ca SHA512 e2d87373e00b65756d7fea40c54fb236d7a37ce839145c3afd99ab26efdc17796e540c021e2c24e521df2d0a01ccbf918994f87a0d83235ff9b109a51555b3d0
 DIST notmuch-0.28.4.tar.gz 922364 BLAKE2B f22d52ecc982b086b5d2a67d3b9ae4a379bdcb9e9acf3e77060fd7d97439347e3b4cd767f2c9c3c48657b80f63316f6abc09a653d6791e27b4a8996adccf42a9 SHA512 77d7ad81e1f7dc93ae6392346da434f6dc74c21d19be728c2a6ca283c429f36e7081387d223af58eb5f63f5d2a8ad8367f0103f0bb9d052890c07fe419abbee7
 DIST notmuch-0.29.1.tar.xz 660352 BLAKE2B d145aba2d1a376e8cbcff3d51f9a7093649912a54273f91cce2a56fb414e222c2bbf0aeb510894278bf7dca8a96412400d55897a4d42281ab9c110d9bc8207a6 SHA512 9b76a7c8c62cb67b64a0008f80a82eeecccd20267ddba67d4d96a768815466c305f154769947bb9526e02c7a1696faaf69e94b90007603b185589be0c7c2a5d8
+DIST notmuch-0.29.2.tar.xz 660520 BLAKE2B f87889db5fa1049b2b91a9ea8abe917e5645860a5c163c73a57197ede904aa335c0f3b37cc2a7ff2465c30e94eb25b113bebd074aa9e92c84383457600e1de82 SHA512 0e345c4ecca8410eedb14154bcb3c327353a0984f30b7fd6c526deefcfe17aa74ca8fb4b4d28e93decca8c8914f7d60ca2c9485750001b14d67d7d33d4721bb3
diff --git a/net-mail/notmuch/notmuch-0.29.2.ebuild b/net-mail/notmuch/notmuch-0.29.2.ebuild
new file mode 100644 (file)
index 0000000..f96e581
--- /dev/null
@@ -0,0 +1,232 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit bash-completion-r1 elisp-common eutils flag-o-matic pax-utils \
+       distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.xz
+       test? ( ${HOMEPAGE%/}/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y.  Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~x86 ~x64-solaris"
+REQUIRED_USE="
+       nmbug? ( python )
+       python? ( ${PYTHON_REQUIRED_USE} )
+       test? ( crypt emacs python valgrind )
+       "
+IUSE="crypt doc emacs mutt nmbug python test valgrind"
+
+CDEPEND="
+       !!<app-shells/bash-completion-1.9
+       >=dev-libs/glib-2.22:2
+       >=dev-libs/gmime-3.0.3:3.0
+       >=dev-libs/xapian-1.4.8:=
+       dev-python/sphinx
+       sys-apps/texinfo
+       >=sys-libs/zlib-1.2.5.2
+       sys-libs/talloc
+       crypt? ( dev-libs/gmime:3.0[crypt] )
+       emacs? ( >=virtual/emacs-23 )
+       python? ( ${PYTHON_DEPS} )
+       "
+DEPEND="${CDEPEND}
+       virtual/pkgconfig
+       doc? (
+               app-doc/doxygen
+               dev-python/mock[${PYTHON_USEDEP}]
+       )
+       test? (
+               app-misc/dtach
+               || ( >=app-editors/emacs-23[libxml2] >=app-editors/emacs-vcs-23[libxml2] )
+               sys-devel/gdb
+               crypt? ( app-crypt/gnupg dev-libs/openssl )
+       )
+       valgrind? ( dev-util/valgrind )
+       "
+RDEPEND="${CDEPEND}
+       crypt? ( app-crypt/gnupg )
+       nmbug? ( dev-vcs/git )
+       mutt? (
+               dev-perl/File-Which
+               dev-perl/Mail-Box
+               dev-perl/MailTools
+               dev-perl/String-ShellQuote
+               dev-perl/Term-ReadLine-Gnu
+               virtual/perl-Digest-SHA
+               virtual/perl-File-Path
+               virtual/perl-Getopt-Long
+               virtual/perl-Pod-Parser
+       )
+       "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+PATCHES=(
+       "${FILESDIR}"/${PV}-0001-Use-loopback-IP-address-rather-than-name.patch
+)
+
+bindings() {
+       local ret=0
+
+       if use $1; then
+               pushd bindings/$1 || die
+               shift
+               "$@"
+               ret=$?
+               popd || die
+       fi
+
+       return $ret
+}
+
+pkg_pretend() {
+       if has_version '<net-mail/notmuch-0.18'; then
+               ewarn
+               ewarn "There are few not backward compatible changes between"
+               ewarn "<notmuch-0.18 and >=notmuch-0.18.  See NEWS file"
+               ewarn "(0.18 section) for details before first use!"
+               ewarn
+       fi
+}
+
+pkg_setup() {
+       if use emacs; then
+               elisp-need-emacs 23 || die "Emacs version too low"
+       fi
+}
+
+src_unpack() {
+       unpack "${P}".tar.xz
+       if use test; then
+               mkdir -p "${S}"/test/test-databases || die
+               cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+       fi
+}
+
+src_prepare() {
+       default
+
+       bindings python distutils-r1_src_prepare
+       bindings python mv README README-python || die
+       mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+       # assure that new Makefile.config will be generated
+       rm -f Makefile.config || die
+
+       sed -e 's@^install: all install-man install-info$@install: all install-info@' -i Makefile.local
+
+       if use test; then
+               append-cflags -g
+               append-cxxflags -g
+       fi
+
+       if [[ ${CHOST} == *-solaris* ]] ; then
+               append-ldflags -lnsl -lsocket   # non-autoconf configure
+       fi
+}
+
+src_configure() {
+       python_setup  # for sphinx
+
+       local myeconfargs=(
+               --bashcompletiondir="$(get_bashcompdir)"
+               --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+               --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+               --without-desktop
+               --without-ruby
+               --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+               $(use_with emacs)
+               $(use_with doc api-docs)
+       )
+       tc-export CC CXX
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       python_setup  # for sphinx
+
+       V=1 default
+       bindings python distutils-r1_src_compile
+
+       if use mutt; then
+               pushd contrib/notmuch-mutt || die
+               emake notmuch-mutt.1
+               popd || die
+       fi
+
+       if use doc; then
+               pydocs() {
+                       pushd docs || die
+                       emake html
+                       rm -r html/_sources || die
+                       rm html/{objects.inv,.buildinfo} || die
+                       mkdir -p ../html && mv html ../html/python || die
+                       popd || die
+               }
+               LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+       fi
+}
+
+src_test() {
+       pax-mark -m notmuch
+       LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" V=1 default
+       pax-mark -ze notmuch
+}
+
+src_install() {
+       default
+
+       if use doc; then
+               doman doc/_build/man/man?/*.?
+       fi
+
+       if use emacs; then
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+       fi
+
+       if use nmbug; then
+               dobin devel/nmbug/nmbug
+               dobin devel/nmbug/notmuch-report
+       fi
+
+       if use mutt; then
+               pushd contrib/notmuch-mutt || die
+               dobin notmuch-mutt
+               doman notmuch-mutt.1
+               insinto /etc/mutt
+               doins notmuch-mutt.rc
+               dodoc README-mutt
+               popd || die
+       fi
+
+       DOCS="" bindings python distutils-r1_src_install
+       use doc && bindings python dodoc -r html
+}
+
+pkg_preinst() {
+       if use mutt && ! [[ -e ${ROOT}/etc/mutt/notmuch-mutt.rc ]]; then
+               elog "To enable notmuch support in mutt, add the following line into"
+               elog "your mutt config file, please:"
+               elog ""
+               elog "  source /etc/mutt/notmuch-mutt.rc"
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}