games-rpg/hatoful-boyfriend-holiday-star: New package
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 7 Jul 2019 21:20:12 +0000 (22:20 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 7 Jul 2019 21:20:12 +0000 (22:20 +0100)
Package-Manager: Portage-2.3.68, Repoman-2.3.13
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-rpg/hatoful-boyfriend-holiday-star/Manifest [new file with mode: 0644]
games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild [new file with mode: 0644]
games-rpg/hatoful-boyfriend-holiday-star/metadata.xml [new file with mode: 0644]

diff --git a/games-rpg/hatoful-boyfriend-holiday-star/Manifest b/games-rpg/hatoful-boyfriend-holiday-star/Manifest
new file mode 100644 (file)
index 0000000..ef343b9
--- /dev/null
@@ -0,0 +1 @@
+DIST Linux-Standalone-20151218.rar 347789456 BLAKE2B bb41ebcde9524f2259e9d9a69e19aedc2820ddcf5fe3f4f418f0bdf8cdc9bc228da8c38761febbd68d3ecef1c5f32a5a98fa70480930d9bbcd8285ee3f25c70a SHA512 c59c6d1b54ed59cecf0e7606bdedf25dfa97c8c658800bbf343282eb36b906a569a6f3614271a307008c9946e61abfa2868a1f5ba73193f13138d52333013f5b
diff --git a/games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild b/games-rpg/hatoful-boyfriend-holiday-star/hatoful-boyfriend-holiday-star-20151218.ebuild
new file mode 100644 (file)
index 0000000..8ed1e04
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop xdg-utils
+
+DESCRIPTION="Holiday-themed sequel to the Japanese visual novel and dating sim about birds"
+HOMEPAGE="https://www.devolverdigital.com/games/hatoful-boyfriend-holiday-star"
+SRC_URI="Linux-Standalone-${PV}.rar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+gui"
+RESTRICT="bindist fetch splitdebug"
+
+DEPEND="app-arch/unrar"
+
+RDEPEND="
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libXcursor
+       x11-libs/libXrandr
+       gui? (
+               dev-libs/glib:2
+               x11-libs/gdk-pixbuf:2
+               x11-libs/gtk+:2
+       )
+"
+
+S="${WORKDIR}/Linux-Standalone"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+       einfo "Please buy and download ${SRC_URI} from:"
+       einfo "  https://www.humblebundle.com/store/${PN}"
+       einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+       exeinto "${DIR}"
+       newexe HB2.$(usex amd64 x86_64 x86) HB2
+       make_wrapper ${PN} "${DIR}"/HB2
+
+       insinto "${DIR}"
+       doins -r HB2_Data/
+       rm -r "${ED}/${DIR}"/HB2_Data/*/$(usex amd64 x86 x86_64) || die
+
+       if ! use gui; then
+               rm "${ED}/${DIR}"/HB2_Data/Plugins/*/ScreenSelector.so || die
+       fi
+
+       newicon -s 128 HB2_Data/Resources/UnityPlayer.png ${PN}.png
+       make_desktop_entry ${PN} "Hatoful Boyfriend - Holiday Star"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/hatoful-boyfriend-holiday-star/metadata.xml b/games-rpg/hatoful-boyfriend-holiday-star/metadata.xml
new file mode 100644 (file)
index 0000000..1dbebd8
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+       <use>
+               <flag name="gui">Install the GUI for configuring screen resolution and input</flag>
+       </use>
+</pkgmetadata>