dev-ml/camlp4: Avoid stack overflow in build.
authorRafael Kitover <rkitover@gmail.com>
Mon, 20 Apr 2020 00:21:20 +0000 (00:21 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 5 May 2020 08:46:35 +0000 (11:46 +0300)
Add ulimit -s 11530000 (set stack limit to 11GiB) to src_compile() to
try to avoid stack overflow errors.

Closes: https://bugs.gentoo.org/644352
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Rafael Kitover <rkitover@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15433
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-ml/camlp4/camlp4-4.04_p1.ebuild
dev-ml/camlp4/camlp4-4.05_p1.ebuild
dev-ml/camlp4/camlp4-4.08_p1.ebuild

index 8bf8d05f279c5176931acd8fc6d32b1de3d98f12..af8352a49da71fc5f611b5194506251a61df85ff 100644 (file)
@@ -33,6 +33,8 @@ src_configure() {
 }
 
 src_compile() {
+       # Increase stack limit to 11GiB to avoid stack overflow error.
+       ulimit -s 11530000
        emake byte
        use ocamlopt && emake native
 }
index fe6e0dc150a568d056b338d561a73a93910f92bf..c7ad55154b10b140e759c7c7107e1cb4630a2b67 100644 (file)
@@ -33,6 +33,8 @@ src_configure() {
 }
 
 src_compile() {
+       # Increase stack limit to 11GiB to avoid stack overflow error.
+       ulimit -s 11530000
        emake byte
        use ocamlopt && emake native
 }
index 0c86d665428c1ae71a85e40673847451201fa70f..731b5432fd930e5eebe41f8be22f41f4d3875d40 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -34,6 +34,8 @@ src_configure() {
 }
 
 src_compile() {
+       # Increase stack limit to 11GiB to avoid stack overflow error.
+       ulimit -s 11530000
        emake byte
        use ocamlopt && emake native
 }