games-emulation/mupen64plus-video-rice: rename USE=gles2 to USE=gles2-only
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>
Sat, 23 Nov 2019 09:52:14 +0000 (10:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 3 Apr 2020 14:56:43 +0000 (16:56 +0200)
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-emulation/mupen64plus-video-rice/metadata.xml
games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.9-r1.ebuild [moved from games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.9.ebuild with 90% similarity]

index 6df8a44e77774ad702d99eb00f29b68193ade29c..2fe7b9cfc1ecdddb69071e8f3254fb891ef532f7 100644 (file)
@@ -5,9 +5,6 @@
                <email>mgorny@gentoo.org</email>
                <name>Michał Górny</name>
        </maintainer>
-       <use>
-               <flag name="gles2">Use GLES2 instead of OpenGL</flag>
-       </use>
        <upstream>
                <remote-id type="github">mupen64plus/mupen64plus-video-rice</remote-id>
        </upstream>
similarity index 90%
rename from games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.9.ebuild
rename to games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.5.9-r1.ebuild
index 07453e8b3b5c069e0524662f4daa06b15dd1cfc0..d2419a2055a435d651341dfb463f04d83d87fe27 100644 (file)
@@ -13,13 +13,13 @@ SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.ta
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="gles2 cpu_flags_x86_sse"
+IUSE="gles2-only cpu_flags_x86_sse"
 
-RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2=]
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2-only=]
        media-libs/libpng:0=
        media-libs/libsdl2:0=[video]
        virtual/opengl:0=
-       gles2? ( media-libs/libsdl2:0[gles] )"
+       gles2-only? ( media-libs/libsdl2:0[gles] )"
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
@@ -67,7 +67,7 @@ src_compile() {
                SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
 
                NO_ASM=$(usex cpu_flags_x86_sse 0 1)
-               USE_GLES=$(usex gles2 1 0)
+               USE_GLES=$(usex gles2-only 1 0)
        )
 
        use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )