dev-libs/crypto++: adjust darwin to new build
authorAlon Bar-Lev <alonbl@gentoo.org>
Sat, 8 Oct 2016 08:08:08 +0000 (11:08 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 8 Oct 2016 08:10:12 +0000 (11:10 +0300)
Package-Manager: portage-2.3.0

dev-libs/crypto++/crypto++-5.6.4-r2.ebuild

index b21a0040628f9d622a5763b76d7b38bda3d2ec2b..81b727a5f91167d3717f653581d7b0b36eeee0e8 100644 (file)
@@ -38,7 +38,7 @@ src_compile() {
        # higher optimizations cause problems
        replace-flags -O3 -O2
        # ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
-       [[ ${CHOST} == *-darwin* ]] && append-flags -DCRYPTOPP_DISABLE_X86ASM
+       [[ ${CHOST} == *-darwin* ]] && append-cxxflags -DCRYPTOPP_DISABLE_ASM
 
        emake -f GNUmakefile all shared
 }