net-analyzer/nagios-plugins-linux-madrisan: new USE=varlink
authorLouis Sautier <sbraz@gentoo.org>
Tue, 5 May 2020 18:32:46 +0000 (20:32 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Tue, 5 May 2020 18:34:34 +0000 (20:34 +0200)
Remove automatic detection of libvarlink, change behavior based on the
value of the new USE=varlink flag.

This required dropping the x86 keyword because libvarlink is not
keyworded there.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
net-analyzer/nagios-plugins-linux-madrisan/metadata.xml
net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26-r1.ebuild [moved from net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26.ebuild with 86% similarity]

index 2485783589cbc380032669518915c6169f4214bf..380090a8861e191a62fdc409f10c6a1c9f57e107 100644 (file)
@@ -7,6 +7,7 @@
        </maintainer>
        <use>
                <flag name="curl">Build check_docker which requires <pkg>net-misc/curl</pkg></flag>
+               <flag name="varlink">Build check_podman which requires <pkg>dev-libs/libvarlink</pkg></flag>
        </use>
        <upstream>
                <remote-id type="github">madrisan/nagios-plugins-linux</remote-id>
similarity index 86%
rename from net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26.ebuild
rename to net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-26-r1.ebuild
index 0e91fa5a72cdb048d03de0be8d479201e1dc965f..a0569e29d79c5d4bc02e64c33a916decfd5482b9 100644 (file)
@@ -14,10 +14,13 @@ SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.t
 
 LICENSE="GPL-3+"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="curl"
+KEYWORDS="~amd64"
+IUSE="curl varlink"
 
-DEPEND="curl? ( net-misc/curl:0= )"
+DEPEND="
+       curl? ( net-misc/curl:0= )
+       varlink? ( dev-libs/libvarlink:= )
+"
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${MY_P}"
@@ -36,6 +39,7 @@ src_configure() {
                # Most options are already defaults for Gentoo
                --disable-hardening
                $(use_enable curl libcurl)
+               $(use_enable varlink libvarlink)
        )
        econf "${myconf[@]}"
 }