x11-terms/terminator: fix usage of distutils
authorAlexey Sokolov <sokolov@google.com>
Fri, 1 May 2020 07:00:50 +0000 (08:00 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 14:10:56 +0000 (17:10 +0300)
Address post-submit comments on #14826

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch [new file with mode: 0644]
x11-terms/terminator/terminator-1.92.ebuild

diff --git a/x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch b/x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch
new file mode 100644 (file)
index 0000000..ae722cb
--- /dev/null
@@ -0,0 +1,25 @@
+commit 9f855d41f3e6d610bd01df9688467fdbb341917c
+Author: Alexey Sokolov <sokolov@google.com>
+Date:   Fri May 1 08:36:09 2020 +0100
+
+    Make failed tests fail the test
+
+diff --git a/run_tests b/run_tests
+index 3bf51e4a..cc7fb56a 100755
+--- a/run_tests
++++ b/run_tests
+@@ -4,10 +4,10 @@ for t in tests/test*; do
+     echo $t
+     file_type=$(file -b $t)
+     case ${file_type} in
+-        *[Pp]ython*) python ${t} ;;
+-        *Bourne*) bash ${t} ;;
+-        *bash*)   bash ${t} ;;
+-        *perl*)   perl ${t} ;;
++        *[Pp]ython*) python ${t} || exit 1 ;;
++        *Bourne*) bash ${t} || exit 1 ;;
++        *bash*)   bash ${t} || exit 1 ;;
++        *perl*)   perl ${t} || exit 1 ;;
+         *) echo "Unknown" ;;
+     esac
+     echo
index 64edc13227e26713eeedc99041527e1ba364fc4c..e0725520a7cd2036b737c06353d82e380803fa2e 100644 (file)
@@ -13,8 +13,7 @@ SRC_URI="https://github.com/gnome-terminator/terminator/releases/download/v${PV}
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="dbus +libnotify test"
-RESTRICT="!test? ( test )"
+IUSE="dbus +libnotify"
 
 RDEPEND="
        >=dev-libs/glib-2.32:2
@@ -30,12 +29,13 @@ RDEPEND="
 "
 BDEPEND="
        dev-util/intltool
-       test? ( ${RDEPEND} )
 "
+distutils_enable_tests setup.py
 
 PATCHES=(
        "${FILESDIR}"/terminator-1.91-without-icon-cache.patch
        "${FILESDIR}"/terminator-1.91-desktop.patch
+       "${FILESDIR}"/terminator-1.92-make-tests-fail.patch
 )
 
 src_prepare() {
@@ -43,8 +43,8 @@ src_prepare() {
        distutils-r1_src_prepare
 }
 
-python_test() {
-       virtx esetup.py test || die "tests fail with ${EPYTHON}"
+src_test() {
+       virtx distutils-r1_src_test
 }
 
 pkg_postinst() {