eababf76189be9dad89d1e42dd577dc480f9a2e6
[gentoo.git] / xfce-extra / xfce4-whiskermenu-plugin / xfce4-whiskermenu-plugin-2.4.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake xdg-utils
7
8 DESCRIPTION="Alternate application launcher for Xfce"
9 HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
10 SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~x86"
15 IUSE=""
16
17 RDEPEND="
18         virtual/libintl
19         x11-libs/gtk+:3
20         xfce-base/exo:=
21         xfce-base/garcon:=
22         xfce-base/libxfce4ui:=
23         xfce-base/libxfce4util:=
24         xfce-base/xfce4-panel:=
25 "
26 DEPEND="
27         ${RDEPEND}
28 "
29 BDEPEND="
30         sys-devel/gettext
31         virtual/pkgconfig
32 "
33
34 src_prepare() {
35         # fix build failure w/ xfce4-panel-4.15.0
36         sed -i -e 's@<libxfce4panel/xfce-panel-plugin\.h>@<libxfce4panel/libxfce4panel.h>@' \
37                 panel-plugin/register-plugin.c || die
38         cmake_src_prepare
39 }
40
41 src_configure() {
42         local mycmakeargs=(
43                 -DENABLE_AS_NEEDED=OFF
44                 -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
45                 -DENABLE_DEVELOPER_MODE=OFF
46                 -DENABLE_LINK_TIME_OPTIMIZATION=OFF
47         )
48
49         cmake_src_configure
50 }
51
52 pkg_postinst() {
53         xdg_icon_cache_update
54 }
55
56 pkg_postrm() {
57         xdg_icon_cache_update
58 }