e3eda54e5608645f5f8c33590654d43ae5b23e36
[gentoo.git] / x11-themes / blueglass-xcursors / blueglass-xcursors-0.4.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 MY_P="5532-BlueGlass-XCursors-3D-${PV}"
5 DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
6 HOMEPAGE="http://www.kde-look.org/content/show.php?content=5532"
7 SRC_URI="http://kde-look.org/content/files/$MY_P.tar.bz2"
8
9 LICENSE="LGPL-2.1"
10 SLOT="0"
11 KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
12 IUSE=""
13
14 RDEPEND=""
15 DEPEND="${RDEPEND}"
16
17 # Note: although the package name is BlueGlass, the tarball & authors directions
18 # use the directory 'Blue'.
19 src_install() {
20         dodir /usr/share/cursors/xorg-x11/Blue/cursors/
21         cp -R "${WORKDIR}"/${MY_P:5}/Blue/cursors "${D}"/usr/share/cursors/xorg-x11/Blue/ || die
22         dodoc "${WORKDIR}"/${MY_P:5}/README
23 }
24
25 pkg_postinst() {
26         einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
27         einfo "and add the following line:"
28         einfo "Xcursor.theme: Blue"
29         einfo ""
30         einfo "You can change the size by adding a line like:"
31         einfo "Xcursor.size: 48"
32         einfo ""
33         einfo "To globally use this set of mouse cursors edit the file:"
34         einfo "   /usr/share/cursors/xorg-x11/default/index.theme"
35         einfo "and change the line:"
36         einfo "    Inherits=[current setting]"
37         einfo "to"
38         einfo "    Inherits=Blue"
39         einfo ""
40         einfo "Note this will be overruled by a user's ~/.Xdefaults file."
41         einfo ""
42         ewarn "If you experience flickering, try setting the following line in"
43         ewarn "the Device section of your XF86Config:"
44         ewarn "Option  \"HWCursor\"  \"false\""
45 }