Convert all URIs for launchpad.net from http to https
[gentoo.git] / x11-terms / sakura / sakura-3.2.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit cmake-utils eutils
7
8 DESCRIPTION="sakura is a terminal emulator based on GTK and VTE"
9 HOMEPAGE="http://www.pleyades.net/david/projects/sakura/"
10 SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86 ~arm-linux ~x86-linux"
15
16 RDEPEND="
17         >=dev-libs/glib-2.20:2
18         >=x11-libs/vte-0.28:2.90
19         x11-libs/gtk+:3
20 "
21 DEPEND="${RDEPEND}
22         >=dev-lang/perl-5.10.1
23         virtual/pkgconfig
24 "
25
26 PATCHES=( "${FILESDIR}"/${PN}-3.1.3-flags.patch )
27
28 DOCS=( AUTHORS )
29
30 src_prepare() {
31         sed -i "/FILES INSTALL/d" CMakeLists.txt || die
32
33         strip-linguas -i po/
34         local lingua
35         for lingua in po/*.po; do
36                 lingua="${lingua/po\/}"
37                 lingua="${lingua/.po}"
38                 if ! has ${lingua} ${LINGUAS}; then
39                         rm po/${lingua}.po || die
40                 fi
41         done
42
43         cmake-utils_src_prepare
44 }