c6eda839fea375dc1bfd7bd544a10e9013cde9a0
[gentoo.git] / x11-terms / qterminal / qterminal-0.9.0.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils eapi7-ver gnome2-utils xdg-utils
7
8 if [[ ${PV} = *9999* ]]; then
9         inherit git-r3
10         EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
11 else
12         SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
13         KEYWORDS="amd64 ~arm ~arm64 x86"
14 fi
15
16 DESCRIPTION="Qt-based multitab terminal emulator"
17 HOMEPAGE="https://lxqt.org/"
18
19 LICENSE="GPL-2+ LGPL-2.1+"
20 SLOT="0"
21
22 RDEPEND="
23         dev-qt/qtcore:5
24         dev-qt/qtdbus:5
25         dev-qt/qtgui:5=
26         dev-qt/qtwidgets:5
27         dev-qt/qtx11extras:5
28         x11-libs/libX11
29         =x11-libs/qtermwidget-$(ver_cut 1-2)*:*
30 "
31 DEPEND="${RDEPEND}
32         >=dev-util/lxqt-build-tools-0.5.0
33 "
34
35 src_configure() {
36         local mycmakeargs=(
37                 -DPULL_TRANSLATIONS=OFF
38         )
39         cmake-utils_src_configure
40 }
41
42 pkg_postinst() {
43         xdg_desktop_database_update
44         gnome2_icon_cache_update
45 }
46
47 pkg_postrm() {
48         xdg_desktop_database_update
49         gnome2_icon_cache_update
50 }