*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / x11-misc / xflux-gui / xflux-gui-1.2.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7
8 inherit distutils-r1 gnome2-utils xdg-utils
9
10 DESCRIPTION="A GUI for f.lux"
11 HOMEPAGE="https://justgetflux.com/"
12 SRC_URI="https://github.com/${PN}/fluxgui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="-* amd64 x86"
17
18 PATCHES=( "${FILESDIR}/${P}-disable-gschemas-compiled.patch" )
19
20 RDEPEND="
21         dev-libs/libappindicator:3
22         dev-python/pexpect[${PYTHON_USEDEP}]
23         dev-python/pygobject[${PYTHON_USEDEP}]
24         dev-python/pyxdg[${PYTHON_USEDEP}]
25         x11-libs/libXxf86vm
26         x11-misc/xflux
27 "
28
29 S="${WORKDIR}/fluxgui-${PV}"
30
31 python_install() {
32         # Don't let the package compiling the schemas,
33         # as this could cause a file collision
34         export DISABLE_GSCHEMAS_COMPILED="true"
35
36         distutils-r1_python_install
37 }
38
39 pkg_postinst() {
40         gnome2_schemas_update
41         xdg_desktop_database_update
42         xdg_icon_cache_update
43 }
44
45 pkg_postrm() {
46         gnome2_schemas_update
47         xdg_desktop_database_update
48         xdg_icon_cache_update
49 }