x11-misc/picom: version bump to 8
[gentoo.git] / x11-misc / picom / picom-8.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 inherit meson python-any-r1 virtualx xdg
8
9 DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
10 HOMEPAGE="https://github.com/yshui/picom"
11 SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MPL-2.0 MIT"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="+config-file dbus +doc +drm opengl pcre test"
17
18 REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
19 RESTRICT="test" # but tests require dbus_next
20
21 RDEPEND="
22         dev-libs/libev
23         dev-libs/uthash
24         x11-libs/libX11
25         x11-libs/libxcb
26         x11-libs/libXext
27         x11-libs/pixman
28         x11-libs/xcb-util-image
29         x11-libs/xcb-util-renderutil
30         config-file? (
31                 dev-libs/libconfig
32                 dev-libs/libxdg-basedir
33         )
34         dbus? ( sys-apps/dbus )
35         drm? ( x11-libs/libdrm )
36         opengl? ( virtual/opengl )
37         pcre? ( dev-libs/libpcre )
38         !x11-misc/compton"
39 DEPEND="${RDEPEND}
40         x11-base/xorg-proto"
41 BDEPEND="virtual/pkgconfig
42         doc? ( app-text/asciidoc )
43         test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
44 "
45
46 src_configure() {
47         local emesonargs=(
48                 $(meson_use config-file config_file)
49                 $(meson_use dbus)
50                 $(meson_use doc with_docs)
51                 $(meson_use opengl)
52                 $(meson_use pcre regex)
53         )
54
55         meson_src_configure
56 }
57
58 src_test() {
59         virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
60 }