7242f202bdd2292419ca75fc9d1794fd465a1265
[gentoo.git] / x11-misc / obconf-qt / obconf-qt-0.14.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake xdg-utils
7
8 DESCRIPTION="Openbox window manager configuration tool"
9 HOMEPAGE="https://lxqt.org/"
10
11 if [[ ${PV} = *9999* ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
14 else
15         SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
16         KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
17 fi
18
19 LICENSE="GPL-2+"
20 SLOT="0"
21
22 BDEPEND="
23         dev-qt/linguist-tools:5
24         >=dev-util/lxqt-build-tools-0.6.0
25         virtual/pkgconfig
26 "
27 DEPEND="
28         dev-libs/glib:2
29         dev-qt/qtcore:5
30         dev-qt/qtgui:5
31         dev-qt/qtwidgets:5
32         dev-qt/qtx11extras:5
33         sys-apps/sed
34         x11-wm/openbox:3
35         x11-libs/libX11
36 "
37 RDEPEND="${DEPEND}
38         !lxqt-base/lxqt-l10n
39 "
40
41 pkg_postinst() {
42         xdg_desktop_database_update
43         xdg_icon_cache_update
44 }
45
46 pkg_postrm() {
47         xdg_desktop_database_update
48         xdg_icon_cache_update
49 }