*/*: Specify EAPI=0 explicitly, to ease greps
[gentoo.git] / x11-misc / lineak-xosdplugin / lineak-xosdplugin-0.9.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils multilib
7
8 MY_P=${P/.0/}
9
10 DESCRIPTION="Xosd plugin for LINEAK"
11 HOMEPAGE="http://lineak.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17 IUSE="debug"
18
19 DEPEND="=x11-misc/lineakd-${PV}*
20                 x11-libs/xosd"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${MY_P}
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}"
28         epatch "${FILESDIR}"/${P}-gcc43.patch
29 }
30
31 src_compile() {
32         econf $(use_enable debug) --with-x
33         emake LDFLAGS="${LDFLAGS}" || die
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" \
38                 PLUGINDIR=/usr/$(get_libdir)/lineakd/plugins \
39                 install || die
40         dodoc AUTHORS README || die
41 }