x11-misc/gigolo: x86 stable wrt bug #717452
[gentoo.git] / x11-misc / gigolo / gigolo-0.5.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit xdg-utils
7
8 DESCRIPTION="a frontend to easily manage connections to remote filesystems using GIO/GVfs"
9 HOMEPAGE="https://www.uvena.de/gigolo/ https://goodies.xfce.org/projects/applications/gigolo"
10 SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 RDEPEND=">=dev-libs/glib-2.16
18         >=x11-libs/gtk+-3.14:3"
19 DEPEND="${RDEPEND}
20         dev-util/intltool
21         virtual/pkgconfig"
22
23 src_prepare() {
24         rm COPYING || die
25         default
26 }
27
28 pkg_postinst() {
29         xdg_desktop_database_update
30 }
31
32 pkg_postrm() {
33         xdg_desktop_database_update
34 }