59e72ccd0e618e209426c0328acec2e3f9700af9
[gentoo.git] / x11-libs / libxcb / libxcb-1.14.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{3_6,3_7,3_8} )
7 PYTHON_REQ_USE=xml
8
9 XORG_TARBALL_SUFFIX="xz"
10 XORG_MULTILIB=yes
11 XORG_DOC=doc
12
13 inherit python-any-r1 xorg-3
14
15 DESCRIPTION="X C-language Bindings library"
16 HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
17
18 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
19 IUSE="doc selinux test +xkb"
20 RESTRICT="!test? ( test )"
21 SLOT="0/1.12"
22
23 RDEPEND="
24         >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
25         >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]"
26 # Note: ${PYTHON_USEDEP} needs to go verbatim
27 DEPEND="${RDEPEND}
28         test? ( dev-libs/check[${MULTILIB_USEDEP}] )
29         doc? ( app-doc/doxygen[dot] )
30         dev-libs/libxslt
31 "
32 BDEPEND="${PYTHON_DEPS}
33         $(python_gen_any_dep '>=x11-base/xcb-proto-1.14[${PYTHON_USEDEP}]')
34 "
35
36 python_check_deps() {
37         has_version -b ">=x11-base/xcb-proto-1.14[${PYTHON_USEDEP}]"
38 }
39
40 pkg_setup() {
41         python-any-r1_pkg_setup
42
43         XORG_CONFIGURE_OPTIONS=(
44                 $(use_enable doc devel-docs)
45                 $(use_enable selinux)
46         )
47 }