Drop arm-linux keyword from tree.
[gentoo.git] / x11-libs / libdrm / libdrm-2.4.92.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"
7
8 if [[ ${PV} = 9999* ]]; then
9         GIT_ECLASS="git-r3"
10 fi
11
12 inherit ${GIT_ECLASS} meson multilib-minimal
13
14 DESCRIPTION="X.Org libdrm library"
15 HOMEPAGE="https://dri.freedesktop.org/"
16 if [[ ${PV} = 9999* ]]; then
17         SRC_URI=""
18 else
19         SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
20         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
21 fi
22
23 VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
24 for card in ${VIDEO_CARDS}; do
25         IUSE_VIDEO_CARDS+=" video_cards_${card}"
26 done
27
28 IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
29 RESTRICT="test" # see bug #236845
30 LICENSE="MIT"
31 SLOT="0"
32
33 RDEPEND="elibc_FreeBSD? ( >=dev-libs/libpthread-stubs-0.4:=[${MULTILIB_USEDEP}] )
34         video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
35 DEPEND="${RDEPEND}
36         valgrind? ( dev-util/valgrind )"
37
38 src_unpack() {
39         default
40         [[ $PV = 9999* ]] && git-r3_src_unpack
41 }
42
43 multilib_src_configure() {
44         local emesonargs=(
45                 # Udev is only used by tests now.
46                 -Dudev=false
47                 -Dcairo-tests=false
48                 -Damdgpu=$(usex video_cards_amdgpu true false)
49                 -Dexynos=$(usex video_cards_exynos true false)
50                 -Dfreedreno=$(usex video_cards_freedreno true false)
51                 -Dintel=$(usex video_cards_intel true false)
52                 -Dnouveau=$(usex video_cards_nouveau true false)
53                 -Domap=$(usex video_cards_omap true false)
54                 -Dradeon=$(usex video_cards_radeon true false)
55                 -Dtegra=$(usex video_cards_tegra true false)
56                 -Dvc4=$(usex video_cards_vc4 true false)
57                 -Detnaviv=$(usex video_cards_vivante true false)
58                 -Dvmwgfx=$(usex video_cards_vmware true false)
59                 -Dlibkms=$(usex libkms true false)
60                 # valgrind installs its .pc file to the pkgconfig for the primary arch
61                 -Dvalgrind=$(usex valgrind auto false)
62         )
63         meson_src_configure
64 }
65
66 multilib_src_compile() {
67         meson_src_compile
68 }
69
70 multilib_src_test() {
71         meson_src_test
72 }
73
74 multilib_src_install() {
75         meson_src_install
76 }