*/*: Bump copyright on files touched this year
[gentoo.git] / x11-libs / libdockapp / libdockapp-0.7.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools font
6
7 DESCRIPTION="Window Maker Dock Applet Library"
8 HOMEPAGE="https://www.dockapps.net/libdockapp"
9 SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
10
11 LICENSE="MIT public-domain"
12 SLOT="0/3"
13 KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
14 # Required for font eclass
15 IUSE="+X"
16 REQUIRED_USE="X"
17
18 RDEPEND="x11-libs/libX11
19         x11-libs/libXt
20         x11-libs/libXext
21         x11-libs/libXpm"
22 DEPEND="${RDEPEND}
23         x11-base/xorg-proto"
24
25 FONT_S=${S}/fonts
26 FONT_SUFFIX="gz"
27 DOCS="README ChangeLog NEWS AUTHORS"
28
29 src_prepare()
30 {
31         eautoreconf
32 }
33
34 src_configure()
35 {
36         # Font installation handled by font eclass
37         econf --without-font --without-examples
38 }
39
40 src_install()
41 {
42         emake DESTDIR="${D}" install
43         font_src_install
44 }